Cycles shows wires always as X-Ray mode

When I close the raytrace viewmode (cycles) and I check the ‘show surface edges’ in the view tab all wires show as x-ray mode, even if I uncheck that feature in the view settings. I’m the only one seeing this?

I don’t see that here, perhaps you can attach a screenshot of a simple cube scene with this behavior?