Cycles experiencing really slow render times

I just installed the latest update. Version 7 SR11
(7.11.21293.9001, 2021-10-20)

I’m experiencing really slow render times even at lowest quality. With or without the denoiser checked and Cycles is now taking a much longer time than before this update. I’m only at 30 out of 50 and it’s taken 22 minutes I can’t get work done at this pace.

One thing I noticed with cycles. Cycles hates mouse clickery it never responds instantly but there is a really long lag and many times it stalls making me have to manually shut down Rhino via task manager. But if I hit escape key Cycles stops instantly and rarely stalls as opposed to hitting the stop icon.

I think in general there is some bad coding in all of Rhino’s mouse code some kind of lag. I see it in view modes and in a lot of different commands. The keyboard seems to work much better than the mouse in general situations where we have an option to click an icon or use a keyboard equivalent.

One other minor thing is that, why is cycles popping up a black screen now and it doesn’t redraw until I move the viewport or wait until 3 render cycles have passed. At least and image though stuck in snow should pop up I think. Currently I always wonder is this even working?

Hi RM - is Cycles using the CPU or the GPU?


Hi @pascal
GPU as that works best, the cpu is even slower.

There have been only three changes to RhinoCycles for 7.11:

Sun/directional light with shadows-only ground plane was really slow:

Do something with shadow intensity of rectangular and linear lights:

Planar environment was rendering upside down:

Of these only the shadows-only ground plane affects speed, in a good way for users - rendering will be fast again.

I don’t know why you would be experiencing suddenly slow rendering times. Maybe a reinstall of your GPU drivers helps…

Hi @nathanletwory
Thanks for your quick response. It’s really a joy now that I can export to “cycles materials” out of 3dcoat, import into rhino and the materials come in perfect when I switch to a physically based material. Renderings are looking great.

I narrowed it down at least for me. It’s the ground plane. If I turn the ground plane off cycles flies again. In a 742 by 425 image if I turn the ground plane off I get a render in 51 seconds if I turn ground plane on it takes over 5 minutes for 10 render samples. I end up killing rhino from the task bar because cycles won’t stop when I press escape or hit the stop icon.

On my ground plane settings no material is checked and I’m rendering to transparent background. There are not many shadow casting objects or that complex of shapes.

Appreciate your patience in helping to sort these issues.

Hmm, the shadows-only ground plane should be fixed in 7.11. I can’t reproduce a slow shadows-only ground plane anymore (with a directional light).

Hi @nathanletwory
Currently I cannot use ground plane in even the simplest of renderings.
I’ve been waiting for the next sr but that might not address this.

I mentioned the fix was in 7.11, but I misspoke. The fix is in 7.12, apologies for the inconvience caused by the misinformation. The branch is rhino-7.12 of the RhinoCycles project, the specific commit is this fix.

Thanks appreciate your help looking forward to the fix.