Cycles broke since weekend?!

raytraced
cycles

#1

today I got back to work and opened a file. worked on it last friday.
all of a sudden cycles gives me strange meshes and lighting.
cycles worked just fine on friday. I open any existing file and start raytraced or rendering and I get these strange results.
here is a simple testscene to demonstrate what I mean:

looks like double meshes and spotlights. there are none of both in the scene.
am I a bug-magnet or what?!
system is i5-6500 and GTX1060 as renderdevice. with CPU it looks a little bit different but also broke.


Cycles makes an interesting image
(Nathan 'jesterKing' Letwory) #2

I haven’t touched RhinoCycles for 8 days now, and no commits to that particulat code for a little longer, so it isn’t me!

I haven’t followed the development work during my vacation, so can’t say why this happens. And the vacation continues still (:

/Nathan


#3

please @nathanletwory turn off your digital devices and enjoy your vacation.
we need you fresh and well recovered when you get back :slight_smile:

luckily I don’t need to render anything important at this time.
really strange though. no wip update over the weekend, no changes to my system or the files and jet this happened.


(Kyle Houchens) #4

try cutting just the geometry from your scene, pasting into a new file and remaking your lights…still funky?


#5

no, doesn’t help.
it doesn’t matter if it’s a newly set up file, copy and pasted stuff or old files. cycles shows the same behavior every time.

the “defects” seems to be more intense when I zoom out:

objects which I zoom in on are less affected:

also a wip repair and an uninstall and reinstall of the nvidia drivers didn’t help.
here is the system-info output:
system-info.txt (1.7 KB)


(Kyle Houchens) #6

can you post the file? I’d like to see if I or anyone else can reproduce this.


#7

sure:
buggy-cycles 001.3dm (275.2 KB)
this is how it looks at my system zoomed in:

and zoomed out:

I guess it will be fine on your system, otherwise more people would have complained about this.


(Kyle Houchens) #8

yep- can totally reproduce it here. Writing it up as a bug-

curiously, if you change the scale to inches and hit yes for scale, it repairs itself, and displays correctly.


#9

WOW, I didn’t expect that, thanks for sticking with me on that.
switching to inches made it disappear, yes.
but when I then switch back to mm or cm it’s back.
unfortunately for me I don’t work in inches :unamused:

EDIT:
Oh, wait! inches is affected too. just 3D-scale the model up and you will also experience it with an inch units.


(Nathan 'jesterKing' Letwory) #10

This sounds like a problem with very large coordinates, a bit like the far from orign problem.


(Kyle Houchens) #11

@nathanletwory there is a YT item on this with associated file- can you take a peek?


(Nathan 'jesterKing' Letwory) #12

I had a peek. Something has changed with how data gets generated and passed on, but I don’t know yet what. I first tested with a WIP from June 13th, that rendered the model just fine. Then I updated to latest, and here we get problem with geometry. Investigation is ongoing.


(Nathan 'jesterKing' Letwory) #13

It looks like this is also possibly related to errors in sampling distribution.


#14

for me it is not a big deal at the moment. I use different files for designing and rendering. so in design and production files I can use mm and for a renderscene I can switch to cm. not convenient but it’s ok for now.
however - as soon as a scene has objects in the background, further away this becomes a problem.
I guess architectural renderings are affected by this the most.


(Nathan 'jesterKing' Letwory) #15

Sure, I am investigating still.


(Wim Dekeyser) #16

Just FWIW, I’m still seeing that effect here - factory-default mm Large objects template.


(Nathan 'jesterKing' Letwory) #17

@wim, just today I returned from a(nother) two week vacation - I haven’t made any changes to this yet, so it is still broken.

For now please select a larger unit (i.e. cm or maybe even m), and apply the suggested scale.