Custom render resolution crashes


#1

I found this bug a while back, but it seems to still exist. When using a custom render resolution (as opposed to viewport resolution) and then hit OK, Rhino freezes and crashes.

As an added note, it would be great if the render settings persisted across models and sessions, rather than have to reset every time Rhino is opened or a new model created.

OpenGL settings:

Software information

  Software versions
    Rhinoceros version:  5.0 Wenatchee 2014-04-21 (510)
    OS X version:  Version 10.9.2 (Build 13C1021)

  Plug-ins
    None

Hardware information

  Computer hardware
    Hardware model:  MacBookPro10,1
    Processor:  Intel Core i7-3740QM CPU @ 2.70GHz
    Memory:  16 GB
    Architecture:  Intel 64 bit

  Video hardware
    Graphics:  NVIDIA GeForce GT 650M 1024 MB
    Memory:  1024 MB
    Screen size:  1440 x 900, 1920 x 1080
    Displays:  Color LCD, DELL E2311H

  Third party kernel extensions
    tc.tctechnologies.driver.PaeFireStudio (4.0.0 14255)
    net.telestream.driver.TelestreamAudio (1.1.0)
    com.paceap.kext.pacesupport.snowleopard (5.9)

  USB devices
    Apple Inc.: FaceTime HD Camera (Built-in)
    Apple Inc.: MacBook Air SuperDrive
    Apple Inc.: Apple Internal Keyboard / Trackpad
    Apple Inc.: Bluetooth USB Host Controller

  Bluetooth devices
    None

OpenGL information

  OpenGL software
    OpenGL version:  2.1 NVIDIA-8.24.9 310.40.25f01
    Render version:  2.1
    Shading language:  1.20
    Maximum texture size:  16384 x 16384
    Z-buffer depth:  24 bits
    Maximum viewport size:  16384 x 16384

  Implementation settings
    Use texture compression:  No

  Appearance settings
    Antialiasing:  None
    Mip map filtering:  None
    Anisotropic filtering:  None

(Marlin Prowell) #2

I cannot duplicate this. Please provide a model and the all the render settings you are using when producing a render so we can duplicate what you are seeing.


#3

Well, for whatever reason, using the newest version this doesn’t seem to crash any longer!

Consider this no longer a bug!