Custom preview with material from path?

Hi Guys.

I used to be able to set the material for the custom preview component directly by supplying a file path.
Here a minimal example:
image
Since a while (sorry, not sure how long - this has been on my ToDo list for a while) it throws the shown error:
“1. Object reference not set to an instance of an object.”

I’ve tried using the file path component, but not success, and can’t find any hints online.
Was there an update to grasshopper somewhere? Any ideas why this is no longer working?

When I found the possibility to point directly to materials via a path I was super excited last year. That was very handy. Would be a shame to lose this functionality now.

Thanks a lot for any hints!

1 Like

It looks like the problem may be with your planar surface, not the material.

FYI this still works fine for me:

If I plug rubbish into the M input then the component still works, so I’d say the problem is with G. Try a different geometry:

image

1 Like

Hi Matt.
Thanks for your response.
In fact you are right: with the sphere it works. Interestingly, however, after the sphere I switched back to the plane surface - and it works now, too. As do all the different surfaces in my ordinal definition!
Very interesting. Let’s hope it stays like this.
So, sorry for the spam :frowning:

P.S.: I also did an a Windows update on the weekend. Maybe that fixed something… who knows.