Custom Preview doesn't Disable Preview

I have a serious problem with Custom Preview whih lately has stopped responding to “Disable Preview”. I have to disable the entire component in order to stop it from Previewing.

bild

Has some default system settings changed lately or has a bug crept in?

My preview settings should be OK:

bild

// Rolf

If you are in Rhino “rendered mode”, you have to uncheck “Render” (right click on component Icon).
image

That was it! Thank you.

Is this a new feature or has it been there all the time? (this phenomenon is new to me anyway, since a few weeks).

All my Custom Preview components seem to have the “Render” setting activated, and I know for sure that I didn’t set them to Render.

// Rolf

It is a “new” feature since Rhino 6 I think.

Yeah it’s fairly new. The custom preview will send meshes with real materials to the render-like displays in Rhino, including Rendered, Arctic, Raytraced, and whatever RDK-compliant render engine is currently active.