Custom Display of Pointclouds not working on Rendered display modes

Using Custom Preview component to display pointclouds doesn’t work on the following Display Modes: Rendered, Artic, Raytraced, ProRender, Realistic. I’m using volvox to import the clouds so I’m not sure if i is specific to Point clouds generated with the volvox components.

Hi Filipe -
I’m not seeing that here with a simple test in Rhino 7:

Hello Wim,

Why are you using a Geometry component, between the Cloud output and the Custom Display Geometry input? If that geometry component is left out the behavior I mentioned is visible. With wireframe / hidden / shaded display modes the points are visible but not in Rendered display modes.

The same is true for curves:

Assuming it’s intentional, it’s an odd design choice. Why wouldn’t one want to render points/curves in rendered/arctic mode? Also, parameter geometry shows up in rendered/arctic mode. Anywho, you can cluster the custom preview and check the Preview Contents right-click option to override this behaviour:

Thanks @AndersDeleuran! I see this is a longstanding quirk. I was also not sure if it was a bug.
There are good reasons why you would want a point cloud to show in Render view modes. For instance, while using VisualArq and to model over a pointcloud survey. VisualArq template uses a render display mode in the perspective viewport.

1 Like