Custom button won't show up

I do all that was explained, but still my custom button ive made wont show up when opening the template. any ideas?
Version 7 SR28
(7.28.23058.3001, 2023-02-27)

“Default units and grid settings are stored in your template file. So, Open Rhino with your standard template - the one you like to use the most - then modify the settings as you want. Then from the File menu, hit “Save as Template” and re-save the file, overwriting the original. Then when you open a file using that template, you should always have your settings. Also make sure that the first time you open a new file with this template that you check “Use this template when Rhino starts”. You can also set the default template file in Options>Files.”

@Mikele_Schnitman - I’ve moved your question to a new topic.

1 Like

Dammit Dale! I just answered the gentleman in the original thread. I need to type quicker.

1 Like

So I opened my template file, I made a custom tool bar, I made a button in it for toggling toggle view mesh hide/show.
saved as a template, still not showing when opening the template again.
Are you saying the script to do the toggle is a “plugin” and I need to save it somewhere and create a plugin folder?


Hi Mikele - toolbars are not part of any Rhino file. So if you made a custom toolbar, and closed Rhino, that toolbar should show up the next time you start Rhino provided the toolbar was added to the last instance of Rhino to close. It is best, if you make such modifications, to save the ‘defualt.rui’ toolbar file under a different name than ‘default’ from Options > Toolbar page > File menu.


1 Like