Curves Not Dark Enough When Exported As Pdf

What’s best practice in Rhino 7 on making the outlines of the parts more visible when exported to .pdf?
I exported some files as .dwg, .dxf, .PDF and .jpg (for good measure) to provide to a small machine shop out of town for a request for a quote on making the parts.
On the phone I asked if he had a CNC mill and he said he did.
I am no CNC machinist but from that I assumed he had AutoCAD or something similar.
When I drove up to the big city to see him days later he told me that he had downloaded the files and then asked if I had any prints. From that I assumed he either couldn’t open the .dwg and/or the .dxf files or was perhaps unfamiliar with AutoCAD.
So I printed some.pdfs and .jpgs to mail to him. The annotations are legible but the leaders, dimension lines and outlines of the parts themselves are barely visible (not dark enough to make out the shape of the objects). Please see the image of the pdf I scanned and saved as a .jpg

Thanks. ~ David

Hello- there are settings in the Print dialog to beef up curves -


Hello Pascal,
Those look just like mine.
If only I could get the PDF to look this good.

~ David


Should I change Default line from Hairline to something else?

~ David

Pascal, Do the Print dialog settings affect the line width which is then exported as a PDF?
I exported (Saved As) the files as PDF then printed them using a large Canon printer at the county library. That’s what I scanned and uploaded in my first post.

EDIT: I copied the converted files to a thumb-drive and printed them using the library’s Canon printer.
~ David

just a thought here, what layers are your 2d lineworks on ?

Hi milezee, I typically rename the current layer to the name of the part, e.g. 4449_Airfoil_Hotwire_Template_Bottom_11_24_22 unless I use Make2D, as was done for this file. Hence the curves show up in the Curves layer as is generated by the Make2D process. I then use the Convert command to, as John Brock suggested, convert the curvy line (not lines, circles, and arcs, but everything else), to chains of arc segments in order to produce something usable for generating G-Code. ~ David

Hi David -
You didn’t post your 3dm file, and scanning a print-out will, depending on the settings of that process, reduce the quality of the original to some degree, so I’ll have to guess a bit.

The Hairline is defined 0.0001 mm. If you export as raster, the result will vary with the DPI setting that you pick. More DPI will result in a finer / lighter line.

I you’re only having curves and annotations in the scene, you should export to a vector PDF. The hairline will still be thin but they will be black.

If you need thicker curves, it will depend on the settings for the object or the layers what you can do to make that happen. By default, all layers are set to “Default” and all objects to “By Layer”. If that is the case in your file, you can change that “Default line width” setting in the Print Setup dialog from Hairline to anything else. If the layer or object is not set to “Default”, you can increase the “Scale by” value in that dialog.

Note that, if anything (layer, object, or print setup) is set to “Hairline”, the “Scale by” value will have no impact. Hairlines don’t scale and are always defined as 0.0001 mm.

If you’re still having issues with this, please post the 3dm file.

Hi Wim,

Here you go. Thanks for the help. ~ David
4449_Airfoil_Hotwire_Template_Top_11_24_22.3dm (1.0 MB)

Hi David -

I’m not sure if that means that you tried and failed…?
This is what I get with vector output and default hairlines -
4449_Airfoil_Hotwire_Template_Top_11_24_22.pdf (39.9 KB)


yeh seems ok here too
4449_Airfoil_Hotwire_Template_Top_11_24_22,MILEZEE.pdf (37.6 KB)

I simply uploaded the .3dm file as you requested. I’ll be saving as (exporting) using vector output in the future. Thanks. ~ David

1 Like

I tried export and print to PDF, both seemed fine. Have you tried printing them as a pdf from a layout page ?

Thank you milezee. Apologies for not seeing this sooner. I’ll give it a try.