Curves (lines) render on top in Neon


#1

Curves (lines) appear in front of other objects, no matter where they are in the scene when I use Raytraced with Neon. Any thoughts on what to do about this? I can delete the curves without a problem but dimensions also show through. If I spin the attached scene around and look at it from the back, all the lines I’ve highlighted and the dimension on the lower right show through the solid material. I can delete the curves but I like to add a few dimensions here and there for clients to get a sense of size so I’d like to solve this issue.

As always, thanks for all the help you provide.


(Kyle Houchens) #2

shut off curves in the display tab or goto tools>option>views>display modes>raytraced with neon

-Kyle
www.theoutside.biz


#3

Thanks for the reply.
I was hoping to be able to create drawings with the rendered shapes, some outlines, annotations, and dimensions - all in one pictorial space. I will still be able to do that but it will have to be a composite - layered in photoshop after the fact.


(Wim Dekeyser) #4

Or you could try to do something with the lighting.
On my laptop, I get the curves and dimensions showing through when I turn both the sun and the skylight on [or a light and the skylight]. When I only use the skylight or only a light, then curves and dimensions disappear behind geometry.


#5

Thanks for the reply.
I read your post on the way to work and was very excited. Unfortunately I don’t get the same effect that you do. My lines and dimensions float in front no matter what combination of lights and sun / skylight I use.

But this does confuse me now. I assumed that the problem was inherent in the nature of the ray tracing but if you get a different result on your laptop than I do on my desktop than it must be something else. Maybe a video card setting or something.


(Wim Dekeyser) #6

yea, I guess that was my point - poorly made ;ø)
The fact that you get curves and dimensions shining through is not inherent to using Neon. So, yes, it is ‘something’. Perhaps @andy will chime in with a qualified answer…


(Brian James) #7

Thanks for the report… I’ve filed this as NE-527 (this is not publicly visible at this time). The draw order of annotations is correct but curves always appear drawn in front of shaded objects. I’ve asked that draw order be supported so that the user can choose.