Curves and points no longer visible through surfaces in Ghosted view

Not sure when that change was introduced, but I just noticed that in Rhino 7 when turning on the “Use advanced GPU lighting” option for the Ghosted viewport mode, all the curves and points are no longer visible through surfaces when in Ghosted view. Is that a visual bug, or is intentional change to speed up the rendering in the scene?

I use Rhino Version 7 SR6 (7.6.21110.13001, 2021-04-20), latest Nvidia drivers and Nvidia GTX 1660 Ti.

Notice the two blue curves on the right side of the Rhino Options pop-up window. They are visible if I turn off the “Use advanced GPU lighting” option.

Hi Bobi -

I see the same behavior on Rhino 6.
Are you activating that option to try to solve a specific problem?
-wim

I had it turned on recently as I liked the highlights and overall better picture quality that the GPU achieves in Ghosted view, however, yesterday I turned it off due to the inability to see the curves and points thought the geometry.