Curve Display Error

Try moving your curves back close to the 0,0 World coordinate origin.
Then run ZEA (Zoom Extents All viewports).

Any better

Thanks for the reply.
Those curves are actually quite close to origin. Around 140m distance… (the file I uploaded was in millimeters - forgot to switch that back to meters, but same behavior).

I don’t know what to suggest.
I can’t duplicate the problem here.
If you copy the curves into another file with the same setup does that fix the problem?
If so, that might indicate some sort of viewport corruption in that file.

The file from above is actually a new file, where I pasted some curves from the original file into…
This is not a huge issue, or maybe it is a small bug, that was accidentally caused and will be fixed in the next WIP.
Here is my system info, if that is of any help:

system_info.txt (9.1 KB)

Thanks.
I’ve created a defect report:
https://mcneel.myjetbrains.com/youtrack/issue/RH-58768

Hopefully the developer will find something.

Did you recently update you OS?

Thank you!
Still the same behavior with todays WIP.
Btw. it even happens when I create a new file and draw a single line, as can be seen in the video below!

I am running the current 10.15.4

Cheers

Try going to the OpenGL options in Mac Rhino and turn off “GPU tessellation” Does this make a difference?

Yes that fixes it!

Thanks; Apple led us to believe that they had fixed the issue with GPU tessellation in the latest OS update which was keeping us from using this feature. Looks more and more like this isn’t the case.

Sure thing!

Do you mean GPU-tesselation? Does this run on the CPU if it is deactivated - hence does it speed up the viewport when running on the GPU?

GPU tessellation is an OpenGL feature which gives us a ton of performance improvements for curve/wire drawing, but unfortunately our experience has been that it doesn’t work all that great on Mac GPU drivers. We fall back to another form of tessellation on the GPU when you disable GPU tessellation which in theory shouldn’t perform as well, but as it stands we still can’t really use GPU tessellation on Mac hardware.

1 Like

Thanks for your explanation!
As OpenGL is being deprecated by Apple anyway, implementing this with Metal sooner or later seems to be the way to go I guess?

That’s what we hope. Unfortunately adding metal support is a massive project.

I understand… Probably it will be worth it, as potential performance improvements could be significant - which would be much appreciated, as we saw in this previous thread:


But yeah I totally respect the fact, that this will be a big project.

Side note: I just updated to macOS 10.15.5 and the curve display behavior with GPU tessellation remains the same.

Funny that this is exactly the story we were told when we upgraded from legacy OpenGL to modern OpenGL on Mac. We’ll see

Yeah sure. Since my knowledge is very limited on this topic, I can only judge by seeing other examples/implementations of Metal. Dan also mentioned in the post, that currently there seem to be driver performance differences for the tessellation shaders…

Lets see how this goes. Wishing you all the best!

I’m drafting up a report for Apple today based on this report. Thanks again for bringing it to our attention.

FYI: I am able to reproduce this issue on my MacBookPro13,1 with the RhinoWIP; but NOT with Rhino 6 for Mac 6.27.

Exactly the same here with my MacBookPro16,1.

Sure thing, always a pleasure!

1 Like