Curve colours remain in detail view after layer change in model space

As an example: Make 2D result was in red. I moved a couple of things in the detail view and switched off hidden items etc.

I then went into model space and changed the layer curves were on to default/black. When back in paper space the curves were still red… When I double clicked in the detail view the colour changes to black but then back to red when I double click out of detail view


PS. Should this stuff be posted in paper cuts or in this general Serengeti thread?

Based on your multiple posts about odd display things, I can tell if you are having display driver issues or if Rhino’s display tools are wonky.

Since other people aren’t posting or replying “me too”, I’m leaning towards display issues.

Post a screenshot of the setting in Options > View > OpenGL please

Hi Andy - in the Make2D dialog, what is the Object Properties source in this case? (New setting in V6…)


Hi John/Pascal,

My apologies, I’ve just had a closer look. I had print display on for the detail view.

I can now see that I was using the from input option and not layer but it is a little confusing if you’re not expecting it… With that option selected it creates a 2D set of curves on your current active layer but colours the curves to match the object and also changes the print colour to match the object too.

Seems like overkill?

I’d expect to be able to choose by layer or to create the same colours on your current layer but by colour and not print colour? I can foresee a lot of half printed media being torn up when someone goes to print something which is black but comes out red :slight_smile:

Your display drivers are over a year old. They have been updated by nVidia probably 14 times since then. Installing an update is probably a reasonable idea and may help with the display not updating until you pan/rotate/zoom the view.

That’s a fair point. I try not to update too quickly as it seems to be mostly games stuff which I don’t use.

Thanks for the pointer, I’ll update

Hi John,

I’ve updated drivers and it’s been couple of days but it’s still doing the same thing… I’ll have a look at it later and do a quick video/screen grab