Current anno style auto-change bug

  1. Create a dim or a text
  2. Change its anno style in properties to some other one
  3. Your current anno style is now that.

Can confirm this is the current behaviour of r6.
Although I was quite enjoying not having to go to the options to change the working dimstyle this way. Could we have this as an advanced setting to toggle between the behaviour @Asterisk expects and the behaviour as it is now?

But isn’t this as it should be? And if you want to make just a new style, you duplicate it and make changes to the duplicate?
Sorry didn’t understand your question
Now I see what you mean, that’s indeed not how it should be.

I can’t remember right now how it is working when you change the Layer of an object via properties. The default behaviour of anno style changes via properties should follow that imo.

Hi - You say that the bug is back - I’m not sure but I guess you are referring to this one? If so, that looks like something else, no?

At any rate, looking into the behavior of having the current style update when an annotation’s style is changed in the Properties panel is on the list as RH-52007 and will be looked at again at some point in the future.
-wim

You are correct, that seems like a new bug, the only similarity is that the current anno style auto-switches where it’s not supposed to. Thanks for logging it.

@stevebaer
@Alain

It’s not a tough one. It never worked like this in 4 or 5. It’s an object property change. Not a global current anno style change. Pascal is right 100% on this. Please, it gets in the way way too often and unexpectedly, since nobody’s used to it, 'cause again, it never worked that way before.

I made the change. See RH-52007 for details.
Thanks

1 Like