Cura Says I have surface issue but Rhino says OK

I am new to Rhino so please forgive me.

I tried a new model and struggled through it. I am used to Fusion so this is very different. I tried to make something simple. After a bit of struggling I came up with this primative sanding block.

Everything looked ok so I exported it as a STL and opened it in Cura. Cura said that I had surface issues.

So I went back to Rhino and tried SelBadObjects and ExtractBadSrf based on the McNeel Wiki.

Neither of these turned up a problem.

I have attached my file. (No laughing. :slight_smile: ) If anyone has any suggestions they would be most appreciated.

Sanding Block.3dm (297.9 KB)

If you run MergeAllCoplanarFaces on the smaller piece, you’ll get a better mesh generated from the model.

I would also run the Mesh command first, set the density to be appropriate for STL printing. Hide the NURBS model to protect it.

Next run the Check command on the Meshes. They should be good, but if they aren’t use the MeshRepair tools to tune them up.

FINALLY, export the checked meshes to STL and see if the down process tools like the mesh.

Any luck?

1 Like

Fantastic!!! Thank you both so much!