CTRL+SHIFT solid highlight subobject selection

when I do a subobject selection, say I’m trying to pick a surface within a polysurface, I don’t get a solid outline. Here, the surface is selected, but the visual feedback is suggests I’ve only picked the curve outline
image

I believe this is simply how Rhino works.

Hi,

Your illustration shows the selection of a face of an extrusion. If it was the face of a polysurface you would also see isocurves highlighted.

If there are coincident objects you get a Selection Menu popup when you click, so you know what you are selecting. As you select items you see a description of what you added to the selection in the command history.

If you are bulk selecting (e.g. with a mouse window) you can turn on object selection filters so you only select faces, say.

There seem to be plenty of aids within Rhino to avoid confusion.

  • This is how Rhino works… but it shouldn’t be, which is why I’m asking for this
  • it’s a polysurface, not an extrusion

Are you sure it’s a polysurface? This is what I get when I do a subobject selection on a polysurface.


When I try to do it on an extrusion I get the same result as you.

@siemen, to be fair to the OP, you can create a polysurface that looks like an extrusion by intersecting parts of two objects that don’t include their non-edge isocurves:

1 Like

As the others have stated, @parex, either shrink surfaces to make isocurves land on the surface or make sure that Show surface isocurves is checked in Object Properties:
image

That said, we have a feature request on the list to shade-highlight sub-object selections: RH-34207.
Thanks!

2 Likes