Crv Boolean, possible to pause "preview mesh"?

unhandled

#1

Hi
Maybe this has been answered before but could not find any threads… Is it possible to make rhino not to calculate every click when performing curve boolean? I have a quite dense number of curves from Illustrator and trying to combine them but every time I click in an area it takes about 4-5 min “Creating preview mesh…” Would it be possible to click in all the regions that I want to use and then let Rhino think?
Any help would be appreciated! I have already split the curves in 4 different parts but still very slow…


#2

I think I found some solution… To lower my “absolut tolerence” to 0.1 instead of 0.001 but what will that affect otherwise?!


(Pascal Golay) #3

Hm- yeah, I don’t think you want to do that - it will affect the precision of the results. I don’t think there is a way to turn off the preview - how many curves are there? It seems to me this was sped up at some point, either in V5 or between V5 and 6 - what version and service release are you running? (Help > About Rhnoceros)

-Pascal


#4

Hi Pascal!
Version 6
(6.2.18065.11031, 2018-03-06)
Commercial

And with hardware:
NVIDIA Corporation
GeForce GTX 1060 6GB/PCIe/SSE2
OpenGL version: 4.6.0 NVIDIA 388.13
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-27-2017
Driver Version: 23.21.13.8813

Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24bits
Stencil depth: 8bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

But its painfully slow…


(Pascal Golay) #5

Hi Per - how many curves selected? What’s a ballpark number for the total regions you’re getting to when it slows down?

-Pascal


#6

In a quarter of the file its about 400 crv and they are not pretty with the “points on”


#7

If its any help blommor-460x1000_Split_1-1.3dm (7.6 MB)


(Pascal Golay) #8

Yeah, I see - these are complex curves… FitCrv to .01 or .1 might help some if the resulting refit curves are good enough for your purposes. Am I correct that you want all possible regions in this case? if so, you can use that option and go get a coffee rather than click-click-click.

Hm -but these curves are already in closed regions as far as I can see - I guess I am not sure what CurveBoolean is going to get you.

-Pascal


#9

Tried to get some info what “All regions” meant but nothing in the manual…
And Fitcurve dont seams to do much difference


#10

@pascal but turning down the absolute tolerance speeds up things a lot and okey I want the endpoints to be the same when connecting them to the other parts (maybe I can deal with some handy work there), but how will it affect the precision?