Creating pipe around helix failed


#1

Hello.
I am learning Rhino for now and I have generated the following: a helix around a helix and a helix around a spiral. In both cases I am trying to make a pipe around the (highlighted) helix and it fails. in the first case I agree it is much too complicated. But in the second not that much. Does it have anything to do with the radius of the pipe? I tried to use small radius, like .5, 1 or 2, but it failes either way.
Any suggestions?
Thank you.


(John Brock) #2

Make sure you’re using a pipe radius that is small enough it won’t self-intersect.
For the pipe around the helix, the pipe radius needs to be less than half of the helix pitch.

Does that make sense?


#3

How do I find out what the helix pitch is, given that I have a helix drawn already? I have used very small pipe radius, like even .05, and it still fails.


#4

Also, when I try to do the pipe, after I introduce a start radius and an end radius, it asks for a point for next radius, which gets very confusing. Why would I need that, if the start and end are already given?


#5

If already drawn, you can use the distance command to measure from a point in the helix the the same spot on the next loop around. It is hard to say if 0.05 is small enough, as we don’t have the model, or if there are other things going on. If you post the model, we can give you a more definite answer.

This lets you build a pipe with varying radius, you might use it to build something like a Venturi tube. If you don’t need to set intermediate radii, after setting the start and end radii, just hit enter.

Sam


#6

Thank you for the reply. I upload the model. I hope this will clarify all issues.model.3dm(271.1 KB)


#7

Using a radius size of 0.4, I was able to create your spring. I didn’t try the other curve because I wasn’t sure what to do with it. I succeeded with 0.05 as well but it was hard to see as its thickness was similar to the curve.

I am not sure why I succeeded, but yours failed. I tried to attach my rhino file, but I’m being told it is too large

You can choose your first radius size and not have to enter the value for the second radius. Just hit the enter key for none, and Rhino will apply the first radius generating it all the way through the curve from beginning to end.


#8

Thank you for the answer. I tried again with.4 and it failed. I guess it’s my laptop’s performance that fails this time, not Rhino.