CreateUVCrv Issue

When I try to do CreateUVCrv, it doesn’t work well sometimes.
Please see the picture and the data.
There are 2 objects, and the difference between them is that the upper surfaces edge is applied FilletEdge or not.

I tried CreateUVCrv to the under surface, but as you can see, the result was not same.
I would like to get the same result as the under one, I mean the UV curve with rectangle.

Why the top one can not work like as the another one?

issue_createuvcrv.3dm (1.2 MB)

Hello- I see that - no idea why that is yet… thanks for the example.

RH-66138 CreateUVCrv: UV rectangle missing


Hi, I checked them with various ways, but I can’t figure out why. Maybe is it bug or something?
Anyway thank you for your checking.

How was the polysurface created? Was that done exclusively in Rhino or was it a file import? If it was a file import can you please share the pre-Rhino file?

There’s something odd in the outer trim loop of the surface in question. When it’s part of the polysurface it reports as a surface boundary. When it’s extracted from the polysurface it doesn’t report as a surface boundary. That’s why you get the rectangle for the surface boundary when it’s extracted but not when it’s still part of the polysurface.

Nevermind on my comment above. There was a very subtle bug in the code that only impacted whether the surface boundary was included in the output. We’re on it now.


Hi, I see. Thank you for your support.
By the way, I created the polysurface with Grasshopper. If you need yet, I’ll share Rhino and GH files.
I’m looking forward to fixing it. Thank you.

RH-66138 is fixed in Rhino 7 Service Release 13 Release Candidate