Crash while opening files

Hi! Did anybody experienced Rhino 8 crashing while opening Rhino 7 files?
Could you please advise what to do to solve the problem?

Hi Petras - please run SystemInfo in Rhino and post the results here. If the problem is specific to some files, please send one to tech@mcneel.com, with a link back to this topic in your comments.

-Pascal

Hi Pascal, do you mean copying everything from Rhino System Information, right?
Help, than System Information, and than copy all?

Hi Petras - yes, please.

-Pascal

does file>import (NOT file>open or double click to open) on the file that is crashing work by any chance?

Rhino 8 SR2 2023-12-12 (Rhino 8, 8.2.23346.13001, Git hash:master @ dbefe46c12cda06610a9ab683a211aa3d16f0030)
License type: Evaluation, build 2023-12-12
License details: Stand-Alone
Expires on: 2024-04-04

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 3.9Gb)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics Family (Intel) Memory: 1GB, Driver date: 10-16-2017 (M-D-Y). OpenGL Ver: 4.3.0 - Build 20.19.15.4835
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: Intel(R) HD Graphics Family (Intel) Memory: 1GB, Driver date: 10-16-2017 (M-D-Y). OpenGL Ver: 4.3.0 - Build 20.19.15.4835
> Integrated (slow!) graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.3 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build 20.19.15.4835
Driver Date: 10-16-2017
Driver Version: 20.19.15.4835
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

All files are crashing while opening them.

Hi! I’ve tried this also, but also keeps crashing. Did you have the same problem?

You’re running the smallest video card possible on an antiquated driver, you might be able to get by if you update and reduce the load on the GPU as much as possible (One Viewport, turning off geometry you aren’t working on, stay in wireframe)

Please see our System Requirements

The file crash may be unrelated, please send us an example if possible. Thanks

This may be helpful when updating the Intel HD driver: Updating Intel HD Driver

Thank you for your help! :slight_smile:

Thank you! :slight_smile: