Crash On Block Deletion

I can’t delete blocks in 6.11 (downgraded for reasons of dimensioning) without crashing. No crash dump.

1 Like

Yes, I had several such crashes and I sent crash reports. I’m working with 6.13

Can you provide more details on the workflow that is used here? I start a new file from a factory-default template, create a box at the origin, turn that into a block and press the Del button on my keyboard. That doesn’t crash Rhino here.

This project has too much history for that. I can upload the current project to you if you like.

If you can also provide specific steps to recreate the issue with the model that you upload, yes, please.

It’s easy - just attempt to delete a block. One of the elevation markers will do it, or “camera symbol.” Every block I’ve tried crashes it. Uploading now.

So far no problems here…

-Pascal

Thanks. I’m open to suggestion about what to look for. Of course in the short term there’s no urgent need to delete blocks though I’d like to take some misleadingly-named ones out of the list while that’s on my mind.

I hope you noticed that I’m on 6.11 (for its dimensioning.) I recently down-graded so I suppose that could be the issue. I uninstalled first, and imported ini and ui info from where I’d saved it.

Also Va is in use in this project, which I think explains the many ambiguously-named blocks.

Are you still getting this problem, Ivelin?

Well, it happened 3 times out of 100+ times I used the script for cleaning the blocks.

I get it every time on the file I uploaded.

Hello - if you disable VA, restart Rhino and delete one of the blocks, does it crash?

-Pascal

Thanks Pascal. Yes I do. It doesn’t create a crash dump nor offer to send it. I have to manually close the program which the system reports as unresponsive.

Hello - I am somewhat at a loss - I see that there are some image files used as textures in materials in many many blocks, and these are not in the file you sent - my guess of the moment is that it is related to this but I do not see how to verify.

@djhg - just to make sure - by deleting a block, you mean deleting a block instance - select it in the viewport, Delete, right, you are no deleting definitions in BlockManager? Does it matter if you are in model space, an active detail or a layout?

@fsalla - the user is using Visual Arq, though the crash occurs even with VA blocked as I understand it - I don’t know if it might still be related? any ideas?

-Pascal

Actually that IS where the problem arises. Thanks for thinking of that question. I AM in fact attempting (and failing) to delete them in Block Manager. Sorry I wasn’t clearer about that. I haven’t had any trouble deleting them from the model.

I guess I should purge the materials. Those are legacies from the previous project from which this one was started. I have a string going about ensuring that I can do such things thoroughly. (Purging and Deleting Redundant Elements)

Aha, ok, thanks, I’ve been barking up the wrong tree… still no crashing yet though. The process takes a long time, presumably due to all the block definitions - thousands. I’d Purge before doing anything with blocks. You’ll still have a lot and that in itself does not explain the crash…

-Pascal

I purged blocks and a good number were removed (I don’t think it was more than 100 though.) There are still blocks in the blocks manager which aren’t used in the project though. I think they’re VaObjects objects as well as Va IFC objects. Anyway, a program freeze with an “unresponsive” error is still reported when I attempt to delete just one of the remaining blocks. (the purge was much faster)

I see the 'Unresponsive" for a while but it does come back, ~ 90 seconds or so if I delete the Sled chair definition.

(btw, after deleting that chair, Purge removes an additional 3325 of 3414 block definitions… I suspect SketchUp is involved at some point in this process?)

-Pascal

That’s got to be it. Yes, I am inserting furniture objects from the SketchUp 3d warehouse. I guess I should open them as a separate project and explode the blocks and create 3dm file before inserting them?

Yes, I would open the skp file in Rhino check it over - my guess is there are thousands of meshes - small ones - that can probably be Joined into one mesh.

-Pascal