Cplane cursor position readout incorrect for front and side views

Using Rhino for Mac 5.0.1 (5A858) — For front view, moving the cursor upwards increases the Cplane Y position readout instead of the Z value. For front view the X position readout is correct. For Right view moving the cursor upwards increases the Cplane Y position value instead of increasing the Z value, and moving the cursor to the right increases the X position value instead of the Z value.

The X and Y cursor position readout values work properly in the Top View.

Entering positions for points or lines by hand x, y, z puts the points or line ends in the correct positions, and the resulting displays of the entered items in all 4 view windows are in the correct positions.

I did not use the releases for the previous several releases, but I did not see this behavior on my last real use of Rhino on Feb. 16, 2014.

Rhino for Mac has been very useful for me and I am planning to purchase it soon.

Software information

Software versions
Rhinoceros version: 5.0.1 (5A858)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.3 (Build 14D136)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: iMac14,2
Processor: Intel Core i5-4670 CPU @ 3.40GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 775M 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Western Digital: My Book 1230
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: MacBook Air SuperDrive
Apple Inc.: Apple Keyboard

Bluetooth devices
Apple: Apple Magic Mouse

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.2.7 310.41.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

that’s correct.

in front view, the cplane is only x & y… z is coming straight at you (or- Z axis in front view is perpendicular to your screen)

@paulrspencer Note you can change the readout to world coordinates if that suits you better. Click on the little button in the lower right hand corner just in front of the position readout and change CPlane to World.

Yet another example why CPlane conventions and orthogonal views would benefit from a rethink. ~Dave