Corrupted Files Recovery: Target_name cannot be resolved / IO Read error Unknown data type encountered

Hello, I have a problem with a grasshopper file that apparently got corrupted, please help me I can’t open it and it is a month of work. I have posted this case as a follow up to this post: Recovering Grasshopper File - #5 by Petras_Vestartas but just in case this helps anyone else, I will leave my case below as a new topic:

Here is how everything happened:

  • I was using this temp file “8ffb…” to work in that got created after an abrupt shutdown of my original file “unnamed 7”, for many weeks this temp file worked excelently without any troubles
  • I finished work last night and closed the program saving my files as always
  • Last night, after closing rhino, I was rendering at the same time a video with sony vegas and suddenly the program crashed
  • Today I tried to open the sony vegas and the video project was erased from my computer, I opened rhino and grashopper and the files from grasshoper that I was working on also dissapeared (see the secreenshot where the file says missing)

  • This files I was working with were the temp files from the backup folder, so there is no more backup there (I know this is a popular suggestion to look for)

  • I went on a hunt and used a very good program that detected the erased file. I discovered that not only that file was erased but one new generated “d96b…” on the same day and moment (eventhough I had not generated any other new file myself while using grasshopper) and also got erased
  • I managed to recover both files with this program calle Ontrack data recovery technician (I recomend better than recuva which failed to find this missing file) (302.2 KB) (384 KB)

  • Now I pasted them on the AutoSaved folder where grasshopper stores the autosave and then I open grasshopper and I get the file again on the listing
  • I try to open the file “8ffb…” and now I get this error: Target_name cannot be resolved

  • I then try to open this mysterious file created yesterday “d96b…” and i get: IO Read error: Unknown data type encountered

  • I also checked the recycling bin, because I read on the blog that temp files don’t get automatically erased from the computer but go to the recycling bin so the files don’t get lost, and there were no files. I did an advanced search the Ontrack recovery software on the recycling bin and found that two grasshopper files were erased last night approximately at the time I quitted rhino. They have weird names and almost no weight

$IBE5UTO.ghx (146 Bytes) $ISUV3M5.ghx (152 Bytes)

  • Just in case you need to know I’m using Rhinoceros Version 5 SR14 64-bit 5.14.522.8390 and Grasshopper Build 0.9.0076

I hope this is enough information and that you can help me out recovering my files.

The gh files are damaged, and cannot be recovered. The .ghx file donot contain any useful information other then a path to your onedrive folder. Bad luck I guess. A simple solution for the future:
You may invest in a usbstick or another external drive and create a simple .bat file to automatic copy important data to it. this bat file could be stored in autostart folder, to get executed on system startup.

(By the way, the weirdo names are global unique identification numbers, which almost 100 % guarantee a unique name. Usually used by autosave, to ensure not override existing names)

We may be able to help you reverse your work instead…

1 Like

Hello @TomTom thank you for your answer, I saw that @DavidRutten could manage to open a file with the same problem in the past so I was hoping that someone could manage help me with my files too (I mention this other case on the link at the top of the post). I think that he also mentioned a bug fix that would be available at the start of this year to help open this kind of files with errors.

Could you tell me how you can help me reverse my work? I actually don’t need the whole file but my latest developments so if this can be tracked backwards it could be super helpful and I would greatly appreciate it.


I’m almost sure he cannot help, if saving the file was interupted within the process.

This is because a .gh file data gets binary serialized, if thats not completed, it will be difficult do deserialize it correctly. I mean David has written Grasshopper, but he has not written the de-/serialization functionality which is part of the .Net framework.

In case you are not working on sensitive data, you could create a new forum thread, describing what you have developed, that you lost your data, how you have solved it back in the time (to show your effort), and if people are willing to help you in rewriting the definition. I’m pretty sure that skilled and willing forum members can speed things up for you. It mabe is better to split the task into smaller subthreads if possible. Because people don’t like doing work for others, but instead are interessted in solving particular isolated problems.

1 Like

@TomTom is right. The files do not contain any Grasshopper data. They are very small (that in itself is a red flag for GHX files) and only contain some text:

Basically, it seems some program somewhere decided to replace the file contents with the file URI. Possibly a backup or synching app?

Thank you very much for your answer @DavidRutten ,by chance could you see the .gh file of 302.2 KB that was the actual file that got erased? Almost all my temp files have smaller sizes and therefore maybe is it possible to get something from this file? (302.2 KB)

Regarding those ghx files, it is the first time I encounter them in my computer, and what surprises me the most is that they were on the recycling bin, I am very careful when deleting files from my computer and I have no recollection of haven’t seen them there the day that this file loss happened. From the URI that you have retrieved I can see that this file corresponds to a definition I had downloaded to understand a process, but that I never actually included in my own definition.

Thank you very much @TomTom too for the answer and the time to explain, the data is somewhat sensitive and to be honest I have never asked help on my definitions before and try to do them by myself because I feel very conscious of taking other people’s time. I might recur to the forum’s help this time if David confirms that the “8ffb…” file is completely corrupted and no data can be retrieved. I actually have a video of my work and of the definition but is was recorded with the zoom out so I can not visualize the components (yes, big facepalm here). And definitely I will investigate about this .bat files and get an external drive for them as you suggested.

Kind regards


Looking at David’s image it is referencing a OneDrive folder. I think OneDrive has automatic file versioning and backups- any chance that you can recover a previous version of the file from the OneDrive interface?

1 Like

Hello @Dancergraham , yes indeed I tried to recover the files through the “previous versions” option in “preferences” of the file, but no one was available unfortunately.

Nevertheless thank you very much for the recommendation, I have read in other posts that people were able to recover part of their files through this method.

That bigger file has also been filled with text. A lot more text, don’t know where it came from:

You can open it using Notepad.exe to see for yourself.

wow this is incredibly weird! I am now checking all my files with the notepad:

  • I’ve checked the file from my computer and it gives another result: (302.2 KB)

(it starts in blank and as I scroll down things appear)

  • Also, when I open this second file that I refferenced before I also have a totally different thing: (384 KB)

(this temp file appeared after the program closed for the last time and after the original temp file got deleted automatically)

  • I noticed that this is a similar result to what I get when I open other working files, here I show you the original files from which the temp was created and from a definition that opens correctly:

By chance, could you please try to open or recover the other file I uploaded above “d96b1e…” that got created mysteriosly when all this problem happened? Maybe it is a temp backup file from the original temp backup file, this would be my last attemp to recover the file I suppose.
I put it here so you don’t have to scroll back up: (384 KB)

I see that the contents of the notepad from this file are very very similar to the ones from working files so this has shone a ray of hope in me and if you could try to open it I would greatly appreciate, when I try to open from rhino I got the IO Read error (I shared the screenshot above).

Thank you very much @DavidRutten @TomTom

What you see is binary data. Binary data can be incomplete. If so, its extremely challenging to recover it, if not impossible. This is what I was speaking of at the beginning. .gh files are binary data, ghx are xml like data which can be read by humans.

1 Like

The files I inspected had their contents replaced with regular text. That’s why they could be opened in notepad. If a gh file is intact (or damaged in some binary way) notepad won’t know how to read it. It’ll just assume the bits mean text, so you’ll get junk on the screen.

If a gh file is not damaged, it can be viewed using the GH_IO_FileViewer.exe (I think that’s what it’s called).

If however a gh file is damaged there’s nothing you can do. The file format uses compression so a single bit out place will ruin everything.

By chance did you try opening this file @DavidRutten ? (384 KB)
It is opening really similar to the original file from which the temp was created so maybe something can be made about this one.
Maybe you can recover it as you did in this post: Recovering Grasshopper File

I am trying to find the GH_IO_FileViewer.exe but I can’t, it should be installed in the McNeel folder? Or is it something I have to download? I did a google search and nothing came up.

It should be somewhere inside the grasshopper install folder. It could also just be called FileViewer.exe, I can’t remember and can’t check until I get to the office.

You can load a file using the viewer by dragging it onto the canvas, then without letting go hover over the pagecurl in the upper left corner, then dropping the file onto the magnifying glass icon.