Copy Trim gives Invalid Surface

copy trim gives invalid (112.1 KB)

this is a little bit longer version.

I try to morph a planar-trimmed surface onto a cylinder surface.
I tried Copy Trim, but it gives an invalid surface.
Flow Along Surface gives some mysterious results, basically a seam line.
Spoph is… actually I am not sure how to use this component.

I like to understand why copy trim failed here.
The source surface and the target surface are all good.


Your trimmed surface on your target has no interior edges and there are duplicated edges on the target surface seam which is the possible cause of the invalid surface.

I’m not sure if this is called a bug, anyway, in the meantime, this could be a workaround.

copy trim gives invalid (115.8 KB)


Thank you! This is indeed a good solution.
Actually, I solved this by using your method for the last question I posted. Your method of using Mesh Shadow. I don’t know this component before, and the concise description of it seemingly shows mesh contour merging behavior by light direction(Z axis here). I guess it will sacrifice some accuracy since it deals with Brep->mesh->Brep conversion.

Update: Mesh Shadow didn’t solve this. It leaves a huge gap at the seam position.

I am not sure I understand your meaning.
There are duplicated edges on the target surface seam” - I can understand this part. Because it is a cylinder that is extruded from a regular circle, there must be two edges staying in the same position at the seam.
Your trimmed surface on your target has no interior edges” - I really don’t understand this. Actually, I am not quite sure what I do not understand… but why do interior edges matter here when it copies the UV distribution of geometry(trimmed edges?) on the source surface to the target surface? Does it mean the source surface and the target should be the same kind of surface? Like both trimmed or untrimmed(I tried this, seemingly does not matter). Or does it mean both the source and target should be cylindric or not at the same time?

The valid cylindrical surface should have one interior edge(not duplicated)…

copy trim gives invalid (34.9 KB)

1 Like

Hi Quan,
I am studying the copy trim component. I have some ideas about this problem. If you want to use copy trim, you better confirm that the target and source surface share the same UV parameter. In your example, they have same U number but the V number differ. when i get UV number from dimensions to construct the source surface, every thing is good.

and here is my GH,
copy trim gives invalid (178.5 KB)

How did you get the valid surfaces? Because I opened your definition, but the results are still the invalid one.

Is your idea the same as here?

if i use the GH that i send to you, I get invalid surface too.

then, i change the source surface from surface split to boundary surface, i get trimed surface.

so, i think the outcome type depends on what we feed to copy trim, maybe the type is not important.
here is the new GH,
copy trim gives invalid (146.4 KB)

sorry, i notice that the outcome is different with the surface split…i am working…

Sorry, I can’t solve this problem from GH after I try many times.
however, avoiding this situation, we can move our pattern to stay away from boundary. it’s a little stupid method…

copy trim gives invalid (129.8 KB)

Thanks. I got it!