Copy-Pasting layouts between files = Nonsense

… is not for the faint of heart.


And this is copying into an EMPTY file purged of all it’s annotation styles, so there is no question of having different settings for the same annotation style.
I even get different size annotations for texts using the same style, in the same view !

Even text placement is mucked-up :

Looks more like sabotage than just lazy programming.
What’s going on ?

Hello - hmmm - does it make any difference if whatever plug-in is providing the scale display in the lower right is not loaded? Can you please run SystemInfo and post the results?


It’s Visual Arq.
Not loading it makes no friggin’ difference.

Ahh… I was waiting for that one.

System Nympho.txt (2.0 KB)

I do have the same problem regarding messed up layout position of text when copying and pasting into another Rhino file (the original file was developed while Grasshopper was in use paired to that original file).

If I avoid to open Grasshopper the problem remains.

Anyone having a solution?


Hello - please post an example that shows the problem.


Hello Pascal,
problem can be seen from uploaded screenshots.

In first pic you can see text with correct native layout.
This is the content that has been copied in the “native Rhino6 file” which contains only this content (no previous Grasshopper work).
This content has been than pasted in a “new Rhino6 file” in which I have been working previously with Grasshopper.

In second picture you can see text has changed position, translated (lines instead maintain correct position).

Thanks in advance for any solution hint,

In the first image it looks like the text is justified upper left, and in the second, lower left. My feeling is the justification did not transfer correctly for some or all of the text. If you turn on control points for all the text in both cases, do they look like they are at the same locations? Has the location of the text in relation to the control points changed?

Could this behavior be associated with the setting Options > Files > Imported file layers which has choices of “Use existing layers with matching name” and “Use complete layer tree from source file”? This setting also appears in Rhino.Options.FileSettings.ImportFileLayerMatchingOptions

Thanks for replies ,

  • Helvetosaur: you are right, text justification has changed from upper alignment to bottom

  • David: unfortunatly what you pointed out does not solve the problem, thanks

Now that the cause of the problem has been pointed out I am still searching how to prevent justification changing.