Copy-pasting from groups multiplies objects

It happened to me many times. When copy-pasting (ctrl+shift+selection) fragment of the group it often multiplies 2 or 20 times in the same spot.
I just had a case when it copied 278 times the same item.


Wanna try:
copy-paste issue.3dm (1.9 MB)
Not sure if it can be reproduced elsewhere.

Hello- I am not able, so far, to repeat that - can you please run the SystemInfo command in Rhino and copy/paste the results here?

-Pascal

Hi Pascal
It is not something that happens very often but yes, once in a while it does.
I bet, it has more to do with model workflow (maybe group, within group, inside another group) rather than system config.
Anyway, sysinfo below:
Rhino 7 SR14 2021-12-14 (Rhino 7, 7.14.21348.13001, Git hash:master @ 5ab502b613f84488d00228948505c6f28ebfe598)
License type: Commercial, build 2021-12-14
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [96% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: Radeon Pro 560X (AMD) Memory: 4GB, Driver date: 6-30-2021 (M-D-Y). OpenGL Ver: 4.6.14761 Compatibility Profile Context FireGL 20.45.40.10 27.20.14540.10001
> Integrated accelerated graphics device with 7 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 6-30-2021
Driver Version: 27.20.14540.10001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\CreateQuadMesh (5bf6c0f3-3657-4ad5-834a-bbbb52706a40)\6.0.6914.24116\CreateQuadMesh.rhp “CreateQuadMesh” 6.0.6914.24116
C:\Program Files\Doliwa Workshop\Rhino Nature\Rhino Nature.rhp “Rhino Nature” 1.0.2.42286
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\Rhino 3DM File Version (aa091cb2-d8c0-4944-a17d-b66c80bec4ca)\7.0.7639.20582\RhinoFileVersion.rhp “Rhino 3DM File Version” 7.0.7639.20582
C:\Users\Piotr\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AMDDenoiser\0.5.3\AMDDenoiser.Windows.rhp “AMDDenoiser.Windows” 0.5.3.0
C:\Users\Piotr\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.14.21348.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.14.21348.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.14.21348.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.14.21348.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.14.21348.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.14.21348.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.14.21348.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 7\Plug-ins\NamedPositions.rhp “Named Position”

I have opened the file I have posted to try if I can replicate this issue.
I can, every time, and it is giving me same result of 279 copies.


Here is the video demonstrating this case:
Multiplied copy
Check the different result whether I first select objects or type copy.

Hello- I would disable VisualArq and Elefront and Rhino Nature in Options > Plug-ins page, then close and rte-open Rhino and see if that changes anything.

-Pascal

I can recall this behaviour long time before I had any of these.
Just to confirm my words I have disabled them and restarted session. Same thing.