Copy/paste unhides everything in second instance


#1

I seem to be having something happen lately that is a pain. If I have most of objects in a r5 file hidden so I can focus on a particular task and then go to an earlier instance of that file and copy an item for the new file and paste it in, then everything hidden gets unhidden! Never seen this before. I updated recently, could that have caused the change?


(Wim Dekeyser) #2

I haven’t noticed this before but I can confirm that behavior. What version did you recently update from?

At any rate, I’ve tried this in the Rhino 6 WIP and it doesn’t happen there. Perhaps you could give that a spin?


#3

Not sure what version I was before the latest update. It had been a while though. I tried to open that simple FEA pluging CONCHA and was getting messages that it was compiled for the latest version of R5. I did the update check and was told I had the latest version but then found that I had to click the Service Release to get the latest update and then CONCHA would load. Never seen the unhide on a paste command before that.

Can't use R6 because of all my essential plugins such as ORCA. 

Here is what I just updated to

Version 5 SR13 64-bit
(5.13.60913.21340, 9/13/2016)
Commercial


(Wim Dekeyser) #4

Thanks for providing more clues.
I also had the Concha plug-in installed. I now disabled this and tried it again and now objects remain hidden when pasting from a previous version.

@Juergen, could you look into this?
I also notice that Concha adds its layers to any document no matter if an analysis is being set up or not. In my opinion it shouldn’t.
cheers,
wim


#5

Thanks for the confirmation Wim. I was pretty excited about CONCHA but not if it is going to do this to basic functionality!
I have Scan & Solve so CONCHA was pretty crude compared to it. Even moreso not that I am doing FEA in Fusion 360.

I’ll disable CONCHA then and look to see what it is doing to layers.


#6

Did you update to Concha v1.0.2? I resolved that issue in that version. I hope it’s working for everybody now.

As for the layers, you are right. That could be done better and I will look into that issue.

I am not sure, if you really can compare SnS witch Concha - they follow completely different strategies. Concha cannot deal with 3D solids but focuses on shells and thin structures. That’s what it’s built for. SnS would require a fine resolution to do so. So, they both have their own field of application.


(Wim Dekeyser) #7

I’ll make sure to update! Thanks.

And I agree with you about the comparison with SnS.
I would add that apart from serving another field of application, SnS is also a mature piece of software that has been around for a long time. I hope that Concha continues to be developed in the future.


#8

Juergen,

The new version clears up the copy/paste issue nicely. Thanks.

How do I get the dialog windows I see in your video? Not showing up when I run Concha commands from the command line.

#9

Joseph, you need to activate our panel.
Additionally, a toolbox is located in the install dir. I wonder, why it doesn’t show up after install. It should.


#10

Wim, Concha v1.0.3 creates its layer tree only after a surface being registered for analysis. It also destroys the tree, if there are no more surfaces registered or the plugin is reset. Just updated it on our Food4Rhino-Page.