Copy display mode results in turning on surface edges

I haven’t tested this a lot, but I have noticed something going on with the visibility of surface edges in rendered viewports. Let me see if I can explain without making a video.

Start with a viewport set to rendered.
In the Display panel visibility settings, turn off surface edges.
Go to Edit …Settings
Click on Display Modes
Click on Copy
Click on the display mode that you started with to create a copy
Click Ok

When I do this, my original display mode that I was using change so that Surface Edges is selected.

Actually, making any changes to display modes in the settings dialog boxes seems to turn surfaces edges on.

Hi Peter - I used to see this, or something like it - here, in the latest V6 builds it seems to behave correctly - what SR are you running?

-Pascal

Version 6 SR24
(6.24.20064.12211, 3/4/2020)

Yep, same here, I was going to complain about this as well, but I forgot. I’ve been toying around with Rendered mode a bit lately and every time I changed something Surface Edges got turned back on. I’m on the current RC (last weeks).

@phcreates, @Helvetosaur - Jeff did make a change quite recently that probably is behind the improvement that I see - please check 6.25 when that becomes available - possibly even the next 6.24 RC, and see how that works.

-Pascal