Coordinates and rotation information of blocks

Hi Marika:

Could you tell me if there is a way to have Rhino select the previously selected location a second time? I tried to search for this answer but the words I used in the search phrase are too ambiguous and I get answers to other questions. For instance, pick, all come up with multiple types of answers.

As an example of what I am trying to do. I want to draw a linear dimension between two locations and I do not want an extension line. When I was using autocad (booo!) I would click the first location, the second location, and then right-click. The right-click would instruct autocad to repeat the prior selected location as the position for the end of the dimension extension line.

It is not something that would naturally be done with a right-click, can I make an alias that I typing the command line that means “retake the point you just picked”? For instance, I put “SL” as an alias for select last to have Rhino select the previously selected object.

I hope that makes sense. Writing the question is just as hard as googling it.

Thanks,

Don

Hi Don - is this for making chained dimensions? There is a Continue option in the linear dimension commands for that.

-Pascal

Hi Pascal:

Sorry this was not so clear. I am trying to take measurements between two points and create an aligned dimension with no extension lines. I just restaurant document the distance between two specific locations on a model. I know this can be just as simple as selecting the set point on the dimension line twice in a row. However, frequently trying to dimension complex measures and point clouds. Even tiny movements of the mouse when there are nearby vertices or points behind the intended point in a cloud can cause the third click in the aligned dimension algorithm to select a third unique position and create an undesired extension line.

I was just wondering if there was a shortcut or keystroke that would allow me to respond to a command prompt with the coordinates which were previously selected. I have been using your program for years now so I have forgotten much of my autocad skills, but it seems like in autocad, you could type the @ at a command prompt and it would enter the previously chosen 3-D point. I was able to start the dimension command and then pick+pick+@ to create a dimension line checkpoints with no extension.

Thanks,

Don

image001.jpg

Hi Don - @ or ‘r’ in front of a typed set of coordinates will be relative to the last point picked.

Is that it?

-Pascal

Hi Pascal:

I think I am asking for something that does not exist, but I appreciate you trying.

Hi Pascal:

I drag a lot of JPEG image files into my drawings. As long as I have used Rhino, it pops up a dialog that allows me to put them in is a picture. Yesterday, the dialogue changed and picture no longer shows up. I can still embed a JPEG as a picture if I want to but I have to run the Picture command from the command line to do it. I started a new drawing in Rhino and tried several different JPEG’s in different folders. In each case, when I drag-and-drop a JPEG on a Rhino drawing I get this dialogue:

Can you tell me why picture is grayed out and if there is a way to get it back?

image001.png

What version of Rhino 7 do you have installed? Can you please post your Systeminfo? (Help > System Information)

You bet.

Rhino 7 SR15 2022-2-8 (Rhino 7, 7.15.22039.13001, Git hash:master @ 2833e18992fc4b5cf99bb29c4d8e8add4f02074d)

License type: Commercial, build 2022-02-08

License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.

Primary display and OpenGL: NVIDIA Quadro P4000 (NVidia) Memory: 8GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

Accelerated graphics device with 4 adapter port(s)

  • Secondary monitor attached to adapter port #0

  • Windows Main Display attached to adapter port #1

  • Secondary monitor attached to adapter port #2

  • Secondary monitor attached to adapter port #3

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 1-29-2020

Driver Version: 26.21.14.4219

Maximum Texture size: 32768 x 32768

Z-Buffer depth: 24 bits

Maximum Viewport size: 32768 x 32768

Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino

C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.15.22039.13001

C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”

C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.15.22039.13001

C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”

C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.15.22039.13001

C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.15.22039.13001

C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.15.22039.13001

C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Whether it is related to your issue or not, you should probably update your Nvidia driver. Rhino shows it is over a year old.

Good idea. I updated to latest 511.79 and the problem is the same.

I just tested with the same Rhino and Windows version as you and I’m not seeing this problem. Is this model specific or does this also happen in a new model?

I close all instances of Rhino, opened a new model with no objects, and found a simple photograph taken with a Nikon camera and tried to drag it. I got exactly the same results. I tried it with different templates and different images.

What is particularly strange is I have been doing this for years and it just changed behavior last week.

When I open on my laptop and do the same thing the dialogue looks like this:

Using my desktop, the dialogue looks like this

What I thought was strange and had noticed the first time he did this is that the aspect ratio of the dialog box changed. Before this problem arose, I used to get the dialog box that looks just like the one on my laptop and when this problem started the box got wider, and the options closer together, and picture and wallpaper were both great.

image001.png

image002.png

Can you please go to Tools > Options > Advanced
Type in Eto in the search on top
You should get the Rhino.Options.UseEtoRDK to show up in the list.
Please make sure it’s set to False

Checked. It is.

Ok, then next check - Can you please check in Tools > Options > Plug-ins, that you don’t have the Render Development Kit UI load protected?

No, it’s not loaded:

image001.png

Ok, then that’s the problem. Please check it, so it loads, restart Rhino and the problem should be solved.

Hi Marika

You are right. That was exactly the problem. It has still been loaded before because the dialog box changed right back to what I was used to as soon as I restarted the program.

I do not change plug-ins and I have no idea how it ever became unloaded. Is not a section of the options that I would ever tamper with and it would be very hard to do accidentally.

I could never have found the problem without your help. I would have had to reinstall Rhino from scratch.

You are my hero.

Thanks,

Don

1 Like

Hi Marika:

I use Rhino with point clouds most of the day. They vary in density and I use the point cloud display size to make sparse point clouds look more full but I have to turn that setting back down when I am provided a dense point cloud so the circles of each point don’t overlap. It takes about seven or eight clicks to get to the setting that changes the size of the point cloud points within one of the display modes in the options panel and I do it often.

Could you suggest for me how I could create a macro that I can assign to a button or keystroke that would just raise/lower the size of the point display one level so that I could make quick adjustments to the displayed size of the point cloud dots depending on the density of a specific model?

Thanks,

Don

Hi Don - I cannot rhink of a good way to do this - the not so good way is to make yourself several display modes with varying point cloud styles -

then make a toolbar that sets the display mode accordingly, for each mode. I can probably make you something that will cycle through the modes from a hot key (‘SetDisplayMode’ “Mode name”, but I don’t see a way that avoids changing modes.

Now… there is a test command that draws point clouds in various ways that would bypass the above in any display mode, the big difference is that using `testPointCloudStyle’ is a) an unsupported test command - i.e. use at your own risk, b) it sizes the points in 3d size not pixels and c) it is global and ignores display modes.

Example macro-
testPointCloudStyle Enabled Yes Diameter .5 Style Round Enter

-Pascal