Control Points Out of Control

(Jody Hill) #1

Why do my control points multiply at an extreme level? This happens after I save my work, close the window, and then open it back up.

0 Likes

(John Brock) #2

Saving and reopening a file can not have that effect.
That said, I believe you.
There must be something else going on.

Can you provide a specific sequence of steps to follow so we can see it happen too?

The image you’re showing is what I would expect curves to look like when they are first created using the TextObject command, and before you clean them up to be appropriate for further modeling use.

1 Like

(Jody Hill) #3

Hi John! Thanks for your interest in this issue.

I will get all of the info together for you and hopefully we can figure out what is going on!

0 Likes

(Jody Hill) #4

@John_Brock

Ok so after doing some trial and error experiments on recreating the crazy control points, I have found that it’s not a ‘save as’ issue, but it’s an issue when I ‘export’ as a dxf.

I have attached 5 examples of the same piece, all ‘exported’ as a different pull down option. You can see that points are a manageable number on the default and natural settings, but the other options have way too many points. What is the difference between these settings besides the number of points?

The files I work with are created in Rhino, ‘exported’ as a dxf , then ran through our nesting software to create the cnc file. With that being said, what is the best ‘export’ option for creating these cnc files with the least amount of points? My experiment says either default or natural but I do not know the difference between these two or if there is also a better option.

0 Likes

(John Brock) #5

Okay.
The problem is DXF does not support NURBS curves.
The “fix” is to never send NURBS curves to DWG/DXF that have to be converted on the fly. Make Arcs first.

G-code supports three movements:
1 - Straight lines
2 - Clockwise arcs
3 - Anticlockwise arc
It’s your job to make sure you’re only send supported curves to DXF.

Lines, arcs and circles in Rhino are good to go.
Twisty Rhino NURBS curves need to be converted to arc chains. If you don’t convert them, they will be approximated by hundreds of short straight lines.

Since you need more efficient Arc objects in your DXF/DWG file, you’ll need to convert your wiggly Rhino curves to arc segments before exporting.

Use the Rhino Convert command.
Use these command option settings:
Output=Arcs
SimplifyInput=No
DeleteInput=Yes
AngleTolerance=0
Tolerance=0.01mm or 0.002"
MinLength=0
MaxLength=0
OutputLayer=Current

The tolerance controls how far the arcs will pull away from your NURBS curves. Your machining process and project will determine how much is OK. The distance is in current model units.

Then when you Export to DXF, use the “CAM Imperial” export scheme for inches and “CAM Metric” for millimeters.

Always check your DXF file by opening it in Rhino before you send it for cutting to make sure it looks good.

Another option is to export using the IGES file format. Nearly all CAM applications support curves through IGES. Choose an appropriate IGES export option configuration for your CAM application.

3 Likes

(Jody Hill) #6

I do the convert command with those exact settings on each file in my daily routine. Here is a file from today, ran with the covert command and exported as cam imperial… the files appear fine until I close them and open the exported dxf back up… this is what I get when I reopen :

Any thoughts?

0 Likes

(Pascal Golay) #7

But, how does the Rhino file look? Still correct, presumably… ?

-Pascal

1 Like

(Jody Hill) #8

Yes, if I were to save as the Rhino file it would still look correct.

In my everyday work I do not usually save as a rhino file though because the work is custom and 9 times out of 10 I will never need to re open the file. However, should I make it a habit to save 2 files (a dxf and a 3dm) just in case?

The ultimate goal for me is to make sure that the dxf file I am sending through the nesting software doesn’t cause a glitch for our cnc machine. Is there a way to clean the dxf file up any further? These points just seem to be at such an extreme number even after the convert command and cam imperial export, and it has caused issues when cutting the files in the past.

0 Likes

(Pascal Golay) #9

Hi Jody - there are settings, in the DWG export, for curves - what does that page look like in your export scheme?

-Pascal

1 Like

(Jody Hill) #10

Hi @pascal ,

Sorry for the delay, I have been testing the differences between saving as a dwg vs a dxf. Simply exporting as a dwg is a complete 180 when it comes to my exported files! (I am still converting them as I did when I saved them as dxf and using cam imperial) There are very minimal changes to the points and I have not had any issues with the files so far glitching once sent to the cnc machine.

Is there anything I should keep an eye out for now that I am exporting as a dwg vs a dxf?

0 Likes

(John Brock) #11

Exporting to DWG or DXF should be nearly identical assuming you’re using the same export (conversion) settings.

Can you provide a specific example of something that is different?

0 Likes