Control Objects - Not Visible in Rendered vs Rhino5

When a curve is made into a control object for Cage Edit, in rendered display mode, you can no longer see the curve. You have to go into shaded/other display modes. I can’t see if there’s a toggle for control objects in display mode settings.

I just tried with Rhino 5 though, and you still get to see the control object, in the standard rendered mode. Note, in the Rhino 6 screenshot, the curve isn’t occluded by the mesh.It disappears once I make it into a control (so to get the points back you would have to go into shaded, then to rendered, given that I will often want to deform in rendered).

Hello - in V6, it looks like you need to toggle surface edges on in the display mode - these are off in Rendered. V5 shows control object wires all the time - I don’t know if that was a change made by design but I suspect it was.


Thanks Pascal.

Okay - that’s a shame I think. I do often go back to the display Properties panel and wonder why there isn’t a tickbox for ‘Control’. If it’s by design (which is fine - little old me isn’t worthy to judge the work of the almighty) then I would say maybe there’s just a need for it to be easy to flick it back on, but without having surface edges on too. Just so the only thing that can be focused on is the caged object and the control. Given that a control (curve or surface) is not really close to a surface edge…

I also tried setting a control objects display mode to being Shaded/Wireframe, switched to rendered, and it’s still not visible.

Maybe I’m just too used to working in rendered mode and need to get out of that habit…