Control key now fixes Zoom Wheel over a spot

Hello, I don’t know if this was done with a certain purpose or not, but in latest Rhino 7 version when pressing Control key now the zoom wheel gets fixed over a spot, which makes the unselecting process a little more difficult. I’m reporting this just in case it wasn’t intentional, if not I guess that although it is uncomfortable I will have to get used to it.

Best regards,
Gonzalo Szechter.

Control deselects, and only if you Move wheel it zooms centered on fixed (initial cursor position) spot.

Hello Fred, thank you for the quick response. As an observation, it feels a little strange but I guess I will just have to get used to not be holding the Control key all the time when performing a selection removal, just that.

Best Regards,

Hi Gonzalo,
I guess I’ve been using V7 and really didn’t notice. OK…so new in 7
Best Regards,

It has been intentional, added recently based on some requests:
Zoom: Scrolling mouse wheel with Ctrl/CMD keeps focus on view center : R̶H̶-̶6̶2̶0̶0̶3̶ (

(I am not on V7 yet for production so can’t judge yet if this is getting in the way of doing other things like you mentioned…)


1 Like

Is there any way to disable or re-assign this? Since the last update it is constantly interfering with my selection processes. Sub-object selection and gumball relocation are much more time consuming when you have to constantly be lifting off and re-pressing ctrl-shift between each zoom movement.