Continuity of surfaces

Hi guys, I’m stucked here with this issue from days. I believe it’s a noob issue, but I really need to learn how to do it. As you can see in my viewport, the surfaces aren’t continuos, because I splitted a surface (or that is what I noticed when I splitted it). It’s not only a viewport issue, but as I export it as an obj to 3ds max I see this gap between the surfaces.

s7_edge.3dm (2.1 MB)

you created a singularity with two CVs which are exactly at the same position.

also the long adjacent surface has a degree 1 in one direction, matching this might cause further problems. but first see if rebuilding the 2 coinciding points helps, this is most likely to be the most square trouble maker.

1 Like

Hello - RicardZ’s suggestion looks correct to me - stacking up control points is generally not a good idea unless all points along an entire edge are stacked, then it becomes a single control point. Here, sliding the points apart a little and then MatchSrf for tangency (curved surface to straight) makes a clean transition.



Thank you both guys. I get what you mean, but I can’t handle any good result by just sliding apart those points and matching the surfaces. So could you please attach a file with just those 2 surfaces after you fixed it and show me the options you choose in the MatchSrf menu, so I can see what I do wrong. Sorry for replying so late.

Hello - this is a start,

s7_edge_PG.3dm (628.7 KB)

but you’ll have to make adjustments elsewhere since you’ve already trimmed the surface. BTW, the arrangement at the centerline of the curved surface, where you have two untrimmed edges tangent to one another is not too good- where adjacent edges are tangent, the surface normal direction becomes ‘undefined’ and things can get ugly - for example, OffsetSrf on that surface will not look good. I’d rethink that arrangement.

I think I’d arrange the surfaces something like this:
s7_edge_PG_Maybe.3dm (234.8 KB)

We can quibble about making them simpler etc but something where you don’t try to make a single surface do too much work - separate out ‘main’ shapes and transitions.


1 Like

Pascal thank you really much for this precious help. I watched carefully your first file and I understood what I had to do. I’m fixing everything right now, and I’m really happy about the result. I’ll post the final file, and the renders also as soon as I will finish it. However I still don’t know if I do right, but if I export everything as an obj and import it in 3ds max I still have some gaps between the surfaces. What I’ve done to fix this gaps is to mesh eveything and then use MatchMeshEdge and everything looks fine 'till now (maybe I will just have a bigger amount of meshes), or it’s there another way to do it? Thanks again, and I’m sorry for replaying so late but I had no time to try to fix it.

s7_edge.3dm (11.4 MB)
As I promised here it is. I’m happy for the result, and happier because I learnt something new that improved my quality works. So thanks again Pascal and also RichardZ
Here there are some renders I’ve done