Construct mesh


(David S. Mavrov) #1

I have a set of meshes. I have another set of curves, where the coordinates of some of the vertices have been changed. I need to deconstruct the meshes and construct them again using the same faces and the new vertices. I can’t manage to find a proper sorting method. I need to bypass the use of plugins such as Weaver Bird.

Construct mesh.gh (1.3 MB)


(Tim Stark) #2

to construct the mesh you Need the verticies. These are Points. you got curves, which are defined by 2 Points.
So I don’t know any solution for that. But how did you create the curves? May there’s a way in a few steps before.
For exmaple, If you deconstruct your mesh, and than move the Points and than create mesh afterwards, it should be no problem


(David S. Mavrov) #3

Here is how the geometry was created

Construct mesh_V1.gh (1.4 MB)

And here I tried doing just that, still no luck.

Construct mesh_V2.gh (1.4 MB)


(Tim Stark) #4

I think V2 is the right way. and much simpler than working with curves. And it worked.

I think the Problem is not the construction afterwards, it’s the initial mesh.

(right=initial; left=constructed)

You got some not nice edges and triangles. And becacuse you search for the closest Points to Surface boundary, you get These triangles afterwards.

This will be fixed, when you plug the delaunay right in deconstruct mesh:

Now it still Looks weired, but that’s because you moved the boundary verticies up, und beneath there is a “quad” strcucture, so when moving one of them Points, you get some edges like on the Picture.

If you want the mesh to be “extruded”, so the walls have the same “boundary” at top and bottom, you could filter for the naked edges, Project them at your top curve, and create “new” meshes out of it.


(David S. Mavrov) #5

Can you post the def. It doesn’t work with me for some reason…


(Tim Stark) #6

Construct mesh_V2_re.gh (1.3 MB)
That’s the Definition of the last Picture, just deleted your middle part.
Or you want the Definition for the idea in the end ?


(David S. Mavrov) #7

Very strange behaviour. If I copy your definition it works. If i recreate it step by step it doesn’t. What version of Rhino and Grasshopper do you use?


(Tim Stark) #8

Strange. I use Rhino 6, may that‘s the Problem


(David S. Mavrov) #9

Work anyway now. So thanks a lot :slight_smile:


(Tim Stark) #10

Your welcome :slight_smile: