Constrained Direction Question (changing from perpendicular mode)


(JB) #1

So, you’re making a line, and you like the direction it’s going, so you hit tab and the direction gets constrained. Now, you want the line to end at the same height (or at the same x,y,z axis) as another object. When you point at the desired point on the other object, it automatically makes the line you’re working on end at a perpendicular to that point.

Is there a preference option to change the mode so the line doesn’t end at a perpendicular, but at an x/y/z equivalent to the desired point? Any way other than using SmartTrack, or creating a plane from the desired point on the object and using said plane to cut off the undesired line portion?

I’ve looked everywhere in preferences and in the forums, but I can’t find anything related to my question…it’s possible it’s hiding right under my nose. Thanks in advance!


What rhino commands do you use on a regular basis and think others don't know about?
(Pascal Golay) #2

Hi Jason - you can specify .x ,.y, .z to pick up only some coordtinates of a point.

I’ll see if I can make a little clip to show how this works, I think it is what you want.

Watch the command line where I type in .z and .xy.

-Pascal


(B Design Bg2) #3

That’s helpful. Thanks to both of you for bringing this solution! It saves time. :slight_smile:

Cheers,

Bobi


(Wim Dekeyser) #4

I’m probably slow… From your clip, I can’t see where you are locking the direction.
In this clip, I’m locking the direction towards the closer point on the line. I then use the .x filter to make sure to have the new line constrained to that x-value. But doing that messes up the direction lock. Or?
Dir-Locked-SameX
-w


(JB) #5

Ditto what Wim Dekeyser said… I seem to be losing the tab constraint after using the .x filter.

Think of it this way, using your example: you start your line at the origin, and want to the constrain the vector of the line to go through (1,1,1), and then want it to end at the same topmost height (z) of that block.

Maybe there’s a trick to using your method, I’m just not clever enough to figure it out…:thinking:


(Pascal Golay) #6

I don’t see a good way to do that all in one go… I’ll poke some more…

https://mcneel.myjetbrains.com/youtrack/issue/RH-50319

@jasongberger - Mikko pointed out that it is possible if a little convoluted to make this work with SmartTrack on

  1. Set your start point and Tab direction in say Perspective.
  2. When a tracking line snaps from an Onsap of a location that has the Z Value you like, hold Ctrl briefly to set a Smart point there - then continue to track along the Tab direction in an elevation view until that line intersects with the smart points automatic line… snap using Int.

Is that anything like what you’re after?

-Pascal


(JB) #7

Yes and no…In theory I think it could work, but practically it’s just not working for me.

I just tried your method (switching to an elevation view), but I just couldn’t get that end point to snap on the smarttrack line (only Int is checked). I could see in the perspective view (open to the side) that it seems to want to make that perpendicular connection to the smarttrack line, and sometimes it even ends up running opposite to my desired direction. Maybe there’s an option in preferences I’m forgetting to check/uncheck?

Additionally, I’ve never had much intuitive success using SmartTrack unless I’m working on a plane (which is rare), especially when I have a lot of features in the background of my design; that automatic hovering always makes undesirable points (is there any way to turn off the automatic feature?)


(Pascal Golay) #8

Hi Jason - I’m not sure what is not working but in the image, it looks like you can drag the mouse up and left farther in Right to hit that horizontal int - also, and this might be it, make sure ‘Use apparent intersections’ is set in Options > Modeling aids.

-Pascal


(JB) #9

That’s what it was; I had turned it off because I would often have issues when I was fixing solids. Now it works!

I am still wondering: Is it possible to turn off the automatic SmartTrack, using manual only?


(Pascal Golay) #10

Hi Jason - not sure what you mean… is this possible on the fly without ‘smarttrack’ ? I do not think so - you’d need reference geometry or at least a guide (AddGuide) I think.

-Pascal


(JB) #11

I mean setting a guide point using only the ctrl button, instead of a point getting placed by hovering the cursor over an endpoint.


(Pascal Golay) #12

Hi Jason - you can set the delay in Options > Modeling aids > SmartTarck page to say 5000 or 10000 ms instead of 2000 - then it will wait longer but you can add with Ctrl.

Does that do it?

-Pascal


(JB) #13

Brilliant! I don’t know why I didn’t think of that! Thank you Pascal!