Confused about a network surface


#1

Hello,

I am confused about what I am seeing with this network surface (called curve network in Matrix).

when I zoom in, the surface looks like it is pulling away from the red curve, which is actually a dup edge of this surface (I have since deleted the original input curve for that surface.

when I complete the rest of the surfaces, and join everything up, and check using show edges, I get no naked edges in this area.

My question is, is it still a naked edge? (even though it is not reading as one?) or just a visual thing due to my computer of graphics card or something?

I am running:
Intel I&-4770K, 16gb ram, 2T hd…
Nvidia GEForce GTX 760

thank you in advance.

Best Regards,
Julie


(Mikolaj Jarski) #2

That is probably just a render mesh issue. Switch to wireframe display to check if you can see a gap. I guess you won’t see it if there an no naked edges. Go to Document Properties - Mesh - select “Smooth & slower” to use a denser render mesh.


#3

Hello Mikolaj,

Thank you for your quick reply, I really appreciate it.
Ok, so:

  1. I switched to wire frame, and did not see another edge curve, or a gap, so I am hoping that this is ok.
  2. I switched from “custom” (80% density) to smooth and slower, and this reduced the anomoly, but did not resolve it.
    3a) I switched back to “custom” and changed density from 80% to 100% and that reduced the anomoly a bit as well, but did not resolve it.
    3b) However, one much appreciated benefit is that changing to this "custom/ 100% density " setting, my panning while in lots of zoom has greatly increased its performance.
    (Prior, if I was zoomed in, and then tried to pan, it was like microscopic movement, and I would have to zoom out, pan, and zoom back in again.,.)

may I ask the pros and cons for each of these settings? I am not quite clear on why one versus the other?

Best Regards,
Julie


(David Cockey) #4

Go into Detailed controls under Custom in Mesh and try adjusting some of the settings ; in particular maximum length of edges and maximum distance from edge to surface.


(Pascal Golay) #5

This is not likely to be due to the mesh setting, it just happens that you reset the target in that view at the time you made the change to the render meshes. The slowdown happens when the camera eye point gets very close to the target point in a perspective view, as can happen with Zooming via scroll or Zoom Window. I suggest using Zoom Target (right click on the Zoom Window button by default) to reset the camera and target from time to time or when this slowdown in dynamic zoom occurs…

More info on render - and other meshes from surfaces - in Rhino here: http://wiki.mcneel.com/rhino/meshfaq

-Pascal


#6

Hello Pascal,

Thank you for your reply!

The link you provided seems to be returning an error/ page not found…

I tried searching mesh faq, etc but no joy…perhaps the link has been re-directed?
Best Regards,
Julie


(Wim Dekeyser) #7

Hi Julie,
not the same document but one that is often referred to:
http://www.hydraulicdesign.net/meshes.htm


(Pascal Golay) #8

Hi Julie - The link should be the right one but the McNeel Wiki seems to be broken at the moment - sorry for the inconvenience, we’ll see if we can get that back in action.


This should work now- it seems to be very slow still, but it works.

-Pascal


#9

Hi wim,

Thank you! That was such a well done article, and perfectly titled as “Why do things look wrong when I shade them?”

Best Regards,
Julie


#10

Hello Pascal,

I understand how to get to the “Zoom target” function, but can you advise on “how” to “reset” the camera and target, please> I am not clear on this concept

I got to step one, and saw the asterick-like icon pointer, but then did not know what to do (or why) after that…)

Thank you in advance, and best regards,
Julie


(Pascal Golay) #11

Hi Julie- Zoom Target works be setting the target point and then making a rectangle all around that point that will be the zoom frame - the smaller the rectangle, the more zoom. So the workflow is best if you have an object snap going- say End: ZoomTarget and at the cross-hairs cursor (This tells you that Rhino is looking for a point in space) snap to an and point, mouse down and then drag a little rectangle around the point and let go of the mouse button. This ‘resets’ the camera and target relationship so that scroll-zooming is a little more useful and predictable. Note that if you zoom in really really tight and you want to maneuver the view around it pays to set the view projection to parallel - it will work better than in Perspective projection.

-Pascal


#12

Hello Pascal.

Ok, great, thank you for the direction. I have “reset” my “zoom target”, in the perspective viewport.

(just need to do one viewport(?) and it changes all same?)

thank you, thank you!

that micro snail move zoom was making me worried that something was very wrong with my relatively new computer/ graphics card or some such!

Best Regards,
Julie