Configuring my scroll wheel as a middle mouse button


#1

I have a Logitech VX Laser Revolution Mouse.

According to my understanding I am supposed to be have the Popup tool palette pop up by depressing the scroll wheel.

Under Rhinoceros/Preferences/Mouse I have checked the Middle mouse button to popup the Popup toolbar.

In System Preferences/Logitech Control Center (I just downloaded and installed the latest version) I have set the Scroll Wheel Button to Click/Middle Click. Yet, when I click the scroll wheel in Rhino, Mission Control pops up instead of the Popup palette. I have also tried Advanced Click and chosen button #3, with the same result, Mission Control pops up.

Even when I pick Nothing in the Logitech Control Center, Mission Control pops up when I depress the scroll wheel button.

Any ideas as to what I need to do to have the Popup tool palette popup as it is supposed to when clicking the middle/scroll wheel button?


#2

This sounds like it may be an OS X issue. Have you gone to System Preferences -> Mission Control and disabled all the relevant options there? I think that OS-related functions get first whack at any events (key/button presses) that happen, so if Mission Control grabs that button, Rhino will never get a chance to see it.


#3

Thank you Evan Jones. I never thought to go to System Preferences/Mission Control. I only tried to change the settings in the Logitech Control Center.

I changed in the Mission Control preferences was the Mouse button from Mouse Button 3 to - (below Button 32), which did the trick as far as Rhino is concerned.

The strange thing is, that even though I did this, when I am in my browser for instance, and I push the scroll wheel button (Mouse Button 3) I still get Mission Control, which I thought would no longer be the case. I thought only F9 would work now.