Compiling monkey

I’m getting this error, unable to locate Rhino DotNET SDK 1. unable to locate the native bit-depth Rhino DotNET SDK library 2. unable to locate 32-bit Rhino DotNET SDK library would you like to search for the file manually.
What I think I did wrong, I tried to open a Rhino plug-in file with monkey and now that it wants to open the plug-ins with monkey. It has changed the operating system icons in the Rhino 7/ Plug-ins folder, all the plug-in are showing the monkey box icon. my plug-in no longer works in Rhino 7I get an error of unknown command. HELP!

Hi @cadguy,

The old Monkey compiler for Rhino 4.0 is obsolete.

Use the RhinoScript Compiler (RhinoScriptCompiler.exe) included with Rhino 7. You can find it here:

C:\Program Files\Rhino 7\System

– Dale

Hi @dale ,
A bit of topic, I apologize:
The same C:\Program Files\Rhino 7\System\RhinoScriptCompiler.exe compiler can to used to create .rhp files for Rhino 6?
Or is Rhino 6 still using the old Rhino 5 RhinoScriptCompiler?

Hi @djordje,

I don’t know - have you tried?

Rhino 7 has API’s that Rhino 6 doesn’t. So that will be an issue. And Rhino 7 uses the .NET Framework 4.8. Rhino 6 uses .NET 4.5. This could be an issue.

– Dale

1 Like

I haven’t tried. Thank you @dale
The old Rhino 5 RhinoScriptCompiler also required .NET 4.5, so I assume it’s the same one I should use for Rhino 6.

@stevebaer for Rhino 6 .py files, we should use the old Rhino 5 RhinoScriptCompiler?

You should be able to use the Rhino 7 script compiler for compiling Rhino 6 plug-ins. You need to have the project point at a Rhino 6 version of RhinoCommon instead of Rhino 7.

There isn’t enough “smarts” in any of our script compilers to know if a given python script is going to run properly in an older version of Rhino. I would suggest running the python scripts on the older version first.

1 Like

my original plug-in no longer functions when I opened up a file. when I open
C:\Program Files\Rhino 7\plug-in I no longer have the correct plug-in icon. Somehow I managed to switched to the file opening with monkey box icon.

Thank you @stevebaer .

I just didn’t understand this part:

On which older RhinoScriptCompiler version? I am only familiar with Rhino 5 and Rhino 7 versions of it.

Sorry, that was confusing :slight_smile: I was trying to point out that you should run your python scripts in Rhino 6 before compiling with the script compiler to ensure that they actually will properly run in Rhino 6.

1 Like

Thank you @stevebaer . I am doing that.
So if python script runs without issues inside Rhino 6 RhinoPythoEditor, then there is no reason why a .rhp file created from it, would not run without issues on Rhino 6 as well?
Of course, taken into account that I have .NET 4.8 installed.

Did I understand you correctly?

That is correct

1 Like

Thank you for the help, and apologize for hijacking the topic.

Hi @cadguy,

You haven’t given us much to go on - no sure how to help.

– Dale