CommandPromptPosition affects all Rhinoceros 7 executables


In the sample attached I have made a plugin with a command to hide the native Rhinoceros UI. This command gives a different behavior switching between Rhinoceros 5 and Rhinoceros 7.

TestCommandAffectingMultipleExecutables.7z (63.3 KB)

In Rhinoceros 5 the command affects only the Rhinoceros 5 executable where it is called.

In Rhinoceros 7 instead the command hides the command bar on all Rhinoceros 7 executables opened. I was expecting the behavior of Rhinoceros 5. The change on the other exe seems happening later.

Hi @cavalli.stefano,

Yes, this is true. We sync so multiple Rhino 7 instances can share common settings on Windows.

If you want to run multiple instances of Rhino 7 and have their application settings sync, then launch Rhino’s with different schemes.

– Dale


My actual need however is only to show all Rhinoceros windows on a custom scheme with no UI.
Now I set this at Rhino.exe startup with Rhino_DotNet.dll and RhinoCommon.dll API.

Is it possible to have the scheme settings sample xml file to set this without using .NET?

I mean to switch from the default configuration of a fresh Rhinoceros setup

to the desired below

In the %APPDATA%\Roaming\McNeel\Rhinoceros\7.0\settings\settings-Scheme__SCHEME_NAME.xml I have tried the following

  <child key="Appearance">
    <entry key="WorldCoordinateIconLabelSize">3</entry>
    <entry key="CommandPromptActiveHypertextColor">255,51,153,255</entry>
    <entry key="CommandPromptFontName">Arial</entry>
    <entry key="ViewportTabs">0</entry>
    <entry key="EchoPromptsToHistory">False</entry>
    <entry key="EchoCommandsToHistory">False</entry>
    <entry key="ShowViewportTitle">False</entry>
    <entry key="MainWindowTitle">False</entry>
    <entry key="CommandPromptPosition">3</entry>
    <entry key="ShowStatusbar">False</entry>
    <entry key="ShowMenu">False</entry>
    <entry key="ShowSideBar">False</entry>

But I miss the part of a single view maximized and I obtain only the following without the single viewport maximized

You might make the default template a file with a single viewport.

– Dale

I don’t open a file.
Is the viewport layout saved in the 3dm?


Try setting this :arrow_down:

– Dale

Ok thanks for the support