Command+P shortcut doesn't override MacOS default shortcut

,

MacBook Pro M2
Sonoma 14.0 MacOS
Rhino 8

Rhino 8 → Settings → Keyboard → Command+P

Doesn’t matter what kind of Command macro I use (Initially I’m trying to use ! _PushPull) - it doesn’t override Mac default shortcut, which allways results in opening a printing window

Oof. I think this is a bug. In Rhino 7 for Mac, we definitely allowed you to override the system default shortcuts:

Screenshot 2023-11-30 at 3.18.49 PM

I’ve logged this issue:

RH-78732 Keyboard: Shortcuts: Overriding macOS shortcuts does not work

1 Like

Thank you!!

Sorry for the late response, but I have an idea that this is a bug of MacOs.
I used to create some of the custom shortcuts within MacOs (Keyboard Shortcut settings). It does not work anymore. So there is a huge possibility it’s not a Rhino fault!

Cheers!

Interesting. I wonder if this is by design.

Following up the topic, at the moment this is very well known issue with the many major software developers.It seems like MacOS Sonoma have changed the approach to override the internal shortcuts (at software developing level). Some developers have fixed this issue already within own software.

RH-78732 is fixed in Rhino 8 Service Release 6