Command "Orient perpendicular to curve": snapshot does not work

(ultimate wip)

  • start the command “orients perpendicular to curve”.
  • I select the object to point and click enter.
  • I choose option “on the curve”.
  • I select the curve.
    Then the command says "base point on the curve: snap at the point of intersection between the object selected and the curve does not work, it does not hook up…

Maybe it’s a small bug to fix…

OrientOnCrv seems to be working correctly here for me in the WIP and the perpendicular option is working as well. The ‘on curve’ option for the base point selection makes sense if the object to orient is already on a curve. I might be misunderstanding your workflow though so please post a file to help explain.

Also, this doesn’t have anything to do with the new Snapshots panel right?

Brian, tutto ok. Thanks

Sorry, I’m not sure what you mean. Did the issue go away or do you have a file to explain it in more detail?

I use the command “Orient perpendicular to curve” (I want to orient several copies of the black curve on the red curve).
I use the option “on curve” inside the command.
The command tells me “base point on the curve”: it does not activate a snapshot at the point of intersection between the two curves.
You can try to do the same…
Thank you for your interest, Brian :wink:
Not snapshot orient perpendicolar on curve.3dm (32.5 KB)

I’m not sure I follow - Osnaps End and Int seem to work as expected here, of that is what you meant…

-Pascal

Pascal, I found that the snap “int” does not work (when the command is run).
If I want to choose the intersection point between the two curves I can not activate, it does not automatically engage as it should.

Pasca, Brian, another similar example.
I use the command “Orient perpendicular to curve”, I choose the red circle I want to orient; I choose the “On Curve” option, then select the orientation curve and then the base point on curve: at this time the snap (center) to the circle is not activated (the onsnap is turned on correctly).
Please try, please, following the steps I have set for the above command.Orient perpend to curve_ snap bug.3dm (39.5 KB)

You do not activate the snap (center) while executing the command.

Follow the steps:

  • Orient perpendicular to the curve
  • Select object to orient, send.
  • “on curve” option
  • Select orientation curve.
  • Base point on the curve: at this time the snap center does not activate…

Please, carefully check it out

So far, this works here.

-Pascal

Pascal, sorry if I insist, but the snapshot at the intersection point of the two curves does not automatically activate when running the command.
I repeat, in particular, it does not work when you choose the option “on curve”, then the command tells me: “base point on the curve”: at this time the automatic intersection snapshot does not work (the cursor does not engage at the point of intersection).
I would like other users to experience the same steps…
Not snapshot orient perpendicolar on curve.3dm (32.5 KB)

OK - I don’t know what may be wrong, but this is what I get:

By ‘automatic intersection’ you mean this:

correct?

-Pascal

Exactly Pascal.
If you try to launch the command and then choose “on curve” option, you will see that the snap intersection, even if it is selected, does not work.
I have selected it (snap int) but it does not work. Again, this only happens if you choose the “on curve” option inside the command “orients perpendicular to the curve”.

I’m sorry to repeat and get you stressed. ;-(

The command says “base point on the curve”.
Snap (int) does not activate, either at the point of intersection of the two curves, nor binds to a point chosen on the curve, for example.

@BrianJ - can you take a swing at this if you get a chance and see if you can repeat it? I cannot repeat the problem… Int Osnap fails on OrientOnCrv if the OnCurve option is used, for Davide…

-Pascal

Okay, I think I figure this out and where the bug is. I’ve filed it as https://mcneel.myjetbrains.com/youtrack/issue/RH-39731 and included a video explanation. In short, the menu method of running OrientOnCrv with the Perpendicular option makes Rhino look for a Perpendicular Osnap when choosing the base point of the orientation curve. Perpendicular Osnaps cannot be defined with one point and this also prevents any other enabled Osnaps from working.

Thanks for the report @davide76 ! Part of my personal confusion in reproducing this one was your use of the term ‘Snapshot’, just so you know we have a new panel in the v6 WIP called Snapshots which is essentially named positions and views combined with several other model states such as material assignments. The issue you’ve reported is not related to this new panel.

Pascal, Brian, the important thing is that you have understood the small problem.
Thanks to you for your patience and professionalism.

After several months since this problem was reported, it has not yet been adjusted. This is to restore a trivial snap “int”. I would not like to carry this defect for years and years :wink:

I would like to know if this “defect” within the command has been resolved?
Thanks