Command Line Autocomplete command list

Hello all,

Working in Rhino 6 here, and it seems to me that whenever I have my command line undocked from the main Rhino window and pulled to my second monitor, the command line pull down list no longer appears whenever I start typing a command. However, if I bring the command line bar back to the primary monitor, docked or undocked to the main rhino window, the command line pull down list will work once again.

Does anyone know if there a workaround to this? I usually place the command line to the side monitor to have a bigger view on the modeling window (like the layers, properties, named views, etc…). Any help would be appreciated.


I can not repeat that.
I suspect it has more to do with GPU hardware/drivers and laptop docking stations.

Please run the Rhino SystemInfo command and post the results.

Thank you for taking a look, appreciate the help, please see below for the info requested:

Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Commercial, build 2021-02-03
License details: Stand-Alone

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-5PPVOTG

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 10-28-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 2070 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 4-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 466.11
> Integrated acclerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-12-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
C:\Users\arqa2\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.21089.1448
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Actually, tried lowering the resolution on my computer, and the pull down list is now showing up on the second monitor (with the command list pulled to the side), although not at the exact location on the command bar where I’m typing, but a bit to the right. Is this a resolution problem where it in fact was showing earlier but perhaps way off the second monitor?

Your SystemInfo looks good to me.
Based on the problem description and that changing a display setting changes the “Autocomplete command list”, I think it most likely is a display driver issue.

There is a newer Intel GPU driver.
Installing it might help. It might not either but it can’t hurt.

Thank you for the link. I’ve installed and the latest drivers but the problem is still there, is there an optimal resolution I should be running rhino at? Thanks again.

Your Windows “Display Settings” should list recommended screen resolutions and text scaling

Thanks, so I had both of those on the recommended settings originally when the problem started happening (3840 x 2160, with 250% text scaling), and only started seeing the autocomplete command list after trying a lower resolution (1920 x 1080 with 125% scaling), where it is now showing but at a different location than where the commands are being typed.

I’m also noticing that whenever I try to resize the layers or properties boxes (pulled out to the side), the temporary grayed out rectangle shows up at a different location than where the cursor is showing, even though once I release, the window is sized to the final location where the cursor was, not the gray rectangle. Don’t know if this is related, but any other thoughts that come to mind? Thanks again.

My experience is that Rhino is not managing 4K screens with display scaling very well. I have a number of issues I have filed relating to toolbars for example.