Command is slow to react. please help me

When i enter any command or number on commandprompt, I have to wait approximately 10 seconds each one letter.
Do you know what is happen ?

I tried to re-install Rhinocerous6 and checked my laptop problem.

Hello - please run the SystemInfo command in Rhino and copy/paste the results here.


hello Pascal. that is mine. thank you.

Rhino 6 SR34 2021-2-3 (Public Build, 6.34.21034.07002, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: 教育版 academic 、ビルド 2021-02-03
License details: Cloud Zoo. In use by: H Kanta Family ()

Apple Intel 64-bit macOS バージョン10.16(ビルド20F71) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro13,3
Machine name: MacBook Pro
Language: ja-JP (MacOS default)

AMD Radeon Pro 460 OpenGL Engine (OpenGL ver:4.1 ATI-4.5.14)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: AMD Radeon Pro 460
Displays: カラーLCD (258dpi 2x)

Graphics processors
Intel HD Graphics 530 (1536 MB)
AMD Radeon Pro 460 (4 GB)
Color LCD (1680 x 1050)

USB devices
Apple Inc.: Apple T1 Controller
Logitech: USB Receiver

Bluetooth devices

Third party kernel extensions

Third party plugins
/Users/hi/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libDLRhinoNative.dylib
/Users/hi/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libPolygonCruncherSDK.dylib
/Users/hi/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libSyncData.dylib
/Users/hi/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libomp.dylib
/Users/hi/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libc++.1.dylib

Rhino plugins
/Applications/ “RhinoCycles” 6.34.21034.7002
/Users/hakamadashiori/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
/Applications/ “Snapshots” 6.34.21034.1002
/Applications/ “Grasshopper” 6.34.21034.7002
/Applications/ “PanelingTools” 6.34.21034.1002
/Applications/ “Commands” 6.34.21034.7002
/Applications/ “Renderer Development Kit” 6.34.21034.1002
/Applications/ “RDK_EtoUI” 6.34.21034.7002
/Applications/ “Displacement” 6.34.21034.1002
/Applications/ “IronPython” 6.34.21034.7002
/Applications/ “Rhino Render” 6.34.21034.1002

@BrianJ - any idea about this?
I do not think I’ve heard of this problem.

I thought that problem come from a project. but that problem is happen on new other project…
because i thought this problem come from application.

and this problem is suddenly happen.


in addition to it, when i select command from tool box by using a mouse, that can work.

Kanta Can you try changing your language to Japanese in Preferences > Language in Rhino 6 for Mac? Do you still get a delay when typing commands?

@pascal I have not seen this before, @dan have you?

I am not able to reproduce this. I have basically the same MacBookPro. Here’s what I tried:

  1. In System Preferences > Language & Region, set my primary language to 日本語. I did not change my keyboard input source to remap to romaji or katakana.
  2. Launched Rhino 6.34.21034.07002 and started a new modeling window.
  3. Typed the Line command.

It completed quickly as expected. In Rhino, can you please run the ExportPreferences command and export your preferences to a file and attach it here? I’d like to see if I can reproduce this issue with your settings.

Thank you,