"Command did not register" startup error

In last Rhino 7 WIP (italian) release, at startup, this alert appears:

WIP di Rhino CRhCommandManager::RegisterCommand E…
Command did not register.
- UUID: 06201BC6-AD84-3bc4-A31E-AAFD698-CDB
- English Name: Layouts
- Local Name: Layout


This happened, after last update, in both my Windows 10 64b Italian installations, on two different machines: a DELL Precision M3800 laptop and a DELL Precision T7600 desktop workstation.

At the moment this alert at startup seems not to be followed by any problem, during Rhino use: anyway in a test I tried the command “_Layouts” and it is not recognized as a valid command, while both the commands “Layout” and “_Layout”, they do work.

What could it be?


Hi Gianpietro,
I’m seeing this with another italian user as well. As a temporary workaround you can install English language pack?.

1 Like

Ciao Giuseppe,
it worked! Thank you!

Installing english language, then switching Rhino interface to english, did solve the problem: alert is not appearing anymore. Actually it was not creating any particular issue or crash, but closing an alert at each and every startup was kind of annoying. Now my modeler life is more enjoyable :slight_smile:.

Hope this report of mine will be useful for McNeel developers, anyway.

Thanks again Giuseppe!
Have a nice day.


PS: keeping discussion in english for wider comprehension.

1 Like


You can just click on OK each time Rhino starts, it will just cause an issue when using the command Layouts but Rhino will still be working fine for all the rest.

This will be fixed in next release.

Thanks for reporting!!


If you have installed, this:

Then you might want to disable it in the WIP.

– Dale

Thanks Cécile. The solution of @giuseppe was a good workaround, right now. So no need to click ok at each start: I converted Rhino in english. When the problem will be fixed I’ll turn it back to italian.

Thanks to you for your feedback!


No, nothing like that installed.

Thank you anyway!

  • Gianpietro