Command delay problem

I tried updating. Now I am using SR17. but the problem remains.

OK, sorry again… hopefully someone from McNeel development will respond here with some other things to check/try…

Hello - a shot in the dark but, if you have not, please try disabling ‘GPU Tessellation’ in Options > View > OpenGL page.


Hi - another shot in the dark - are you holding any keys when drawing the curve?
(I couldn’t see any slow-down in the drawing of the boxes but that might be due to the screen grabbing process?)

Another thing to check is if there are any start-up scripts. I noticed that the python plug-in is loaded in that SystemInfo and am wondering if that is being used for anything.

It doesn’t seem like a graphics issue if there is a delay when starting a command, but drawing after that delay seems fine.

How many monitors are you running?
What resolution?
Are you using a laptop docking station or some other device for running multiple monitors?

Thank you for all your great help!

The boxes are indeed delayed by 0.5s. After every command i need to wait 0.5 second before it runs.
The problem is just even more outspoken when I am drawing curves. because it delays 0.5s after i input each anchor point.

I am using a desktop. I tried disabling GPU Tessellation. didn’t work. I disabled my startup script, disable all plugins and the problem remains.

I think it might have something to do with the fact that I did a “Import Options” and migrate my settings from Rhino 5 to Rhino 6. I am trying a complete reinstall this time.

Hmm, wonder if you imported some display mode that is somehow corrupted. Might try punching the “reset to defaults” button in each display mode.

Yes. This is what I suspect. Because I had a lot of specialized display mode, sometimes it causes me problem even when using Rhino 5. but never this laggy though.
I am doing a clean reinstall soon and will let you know.

I uninstalled and reinstalled it. but the problem remains.
Although it seems to me that the imported settings are still there.
Is it possible to set it back to ‘factory settings’?
like a real clean install

Hello - if you have default modes that have been modified - ( as opposed to new custom modes) click Restore Derfaults like so:


and see if the behavior persists when using just that display mode. This does not strike me as a display mode related thing, but … I can’t think of anything else, off hand, either.


Is there any feedback or error report that Rhino can generate and that I can upload here? Everything back to default and same problem. For example, clear cache or sth else I can do?

I really think the “import options” have corrupted the software. How can I dispose of the “imported options” Reinstalling it doesn’t seem to reset it.

What is your Windows display resolution?
What is your Text scaling set to in Windows?
How many monitors are you running?

You custom settings are stored in

There will be two xml files in that directory. Please try

  • close Rhino
  • rename or move those two files (it is ok if the directory is empty)
  • restart Rhino

This will make Rhino use all default settings. If this improves your situation, it would be nice if you could send these xml files to us so we can try to figure out what the cause is.

I am only using one monitor.

text scaling is 225%
Resolution is 2560 x 1440

I tried removing the XML. turns out it didn’t work either :frowning:

EDITI tried making the text scaling back to 100%, the problem still persists.

In this video, I typed a simple Box command. In Rhino 5, the prompt: “First corner of base” pops out immediately.

In Rhino 6 however, the same prompt takes 0.5 second to pop out. Such delay in command makes using the software extremely inconvenient. The problem is exacerbated when I am using the Curve command, in which every point I input has a 0.5 delay.

We get it.
Of course that would be frustrating.
It’s also frustrating to not be able to determine anything that might cause it.

The replies to my questions rule out the possibilities (however remote), that I was suspecting.

If you start Rhino in Safemode, (load the toolbars plugin), does the hesitation persist or go away?

Yes. I tried disabling all plugin even. still persists.

is it my display card’s problem?

or some conflicts with my softwares?

No one knows.
We’re still trying to figure it out.

When you said, “Yes. I tried disabling all plugin even. still persists”, does that mean that running Rhino in Safemode still had the command delay?