Color Swatch Disappeared

My color swatch disappeared when I choose a material on my layers. Ex: I change a layer to plaster and there is no option to change the color of the plaster. It has been like this for a good 6 months now and I cannot seem to figure out how to bring the color swatch back up. If anyone would be able to help out with this, that would be great.

Can you post a full screenshot of your Rhino interface? Maybe there is a divider bar that needs to be dragged to the side in the Layers panel? Clicking on the name Plaster in the Material column opens a floating editor for the material.
Alternately you can edit the material in the Materials panel after it is in the document.

I think this is what you meant, when I clicked on the material for that layer it won’t even label it as plaster when I choose plaster.

Are you clicking on the material section in the Layers panel to open the settings for the Default material? Mine looks like this here in the latest Rhino 7…

If this is what you’re doing too, make sure you are on the latest service release from Rhino - Downloads

You can also click the down arrow on the right of the Default material preview to create a new Plaster material which will be used for objects on that layer. That may provide a solution as well.

I just downloaded the new version to be safe and I am still unable to use the material. I am clicking on the material section in the layers and the pictures I uploaded are what is showing up when I click on them. Not sure if I am able to fix it or not. I have tried resetting my preferences and settings on rhino but nothing does the trick.

@John_Scibello I’m not sure what the issue is with the floating editor for your material from the Layers panel. Can you instead use the Materials panel to create a material, change it’s color and then right click the material preview to choose Assign to layer? Let’s see if that works next.