Cmnd + S doesnt save a grasshopper file on a mac

Hi,
I’ve had this problem for a while now, in Rhino 8 for mac a Gh file doesn’t get saved if I press Command + S, I checked my shortcuts and the alias is saved properly. The solution for me has been to do it manually (File, Save Document) but it’s annoying having to do that every time.

I hope I’m not the only one experiencing this and that there is a solution. Thanks!

Cmd+S works here as expected. Pls run _SystemInfo in Rhino and post back the results

I have the same issue on version 7 and 8 so here are both:
System Info R8.txt (4.6 KB)
System Info R7.txt (7.3 KB)

@dan do you have an idea how to solve this?

I have no idea how to solve this as I, like @Gijs, cannot reproduce this.

First (highly unlikely) guess: are you sure that the Grasshopper window is “key” (aka frontmost window)? I almost hesitate to ask this, but I need to.

Second guess is there is some Grasshopper component that is intercepting this keystroke. If you knowingly have installed other components, you might navigate to the Grasshopper > File > Special Folders > Components Folder and temporarily move these to your Desktop, restart Rhino and Grasshopper and see if you can use Command+S again.

1 Like

I have tried a bunch of things in the last days to try to solve this so I am not 100% certain if it is the second suggestion that solved it, I also uninstalled and installed the program again and moved or deleted some things in the components folder. Anyways, the cmnd + S works now so I am very happy. Thanks for the suggestions!

2 Likes