Cloud Zoo license autoloads on startup?

Hello,
Referring this this KB article on cloud licensing: https://manual.karamba3d.com/1-introduction/1.1-licenses/1.2.4-cloud-licenses
It explains that it must be loaded each time with the Karamba3DGetLicense command, but you can enable it on startup in Options. We actually want it to be manually loaded, as per the manual.

However, we are finding that Rhino is automatically grabbing the Karamba license from the Cloud Zoo on startup, regardless of the plugin’s configuration

I tried disabling it, hacking the registry to change LoadMode = 2 (as needed), but no matter what setting the plugin is configured to, it occupies the license once Rhino loads on the machine.

We’re using the current R6 27, and the latest 1.3.3 Karamba3D plugin. Any feedback would be appreciated.

Hi, if you do not apply the automatic command in the Rhino options, the Karamba3D license will not be loaded from the cloud server.
Then the user simply needs to type “Karamba3DGetLicense” to load the license each time.

Thanks for the reply. This is what we actually want to have happen.
The problem is that Karamba3D is getting loaded automatically as soon as Rhino is started, even though we do not have it setup for automatic. I’ve tried forcing the Load Time setting to both disabled and as needed, but no matter what, Karamba3D gets checked out from the Cloud Zoo.

See below screenshot.

Hi, the plugin should be loaded at the startup, but to actually pull the license you need to run the actual command Karamba3DGetLicense. The license should not be loaded unless it is set up as per the manual instructions. In any case, please write us at info@karamba3d.com.