Cloud Display bug?


just wonder if they Cloud Display is Buggy or did I miss something? I get misterious colors.

For example with spheres:

With Cloud Display:

first time I can’t edit my post to upload the file… (7.4 KB)

It seems the moderator’s tag (for state “handled”) is messing up the poster’s edit mode.

// Rolf

I haven’t marked this one as handled yet.

I don’t think that’s the problem. I’ve experienced this if I accidently touched the tag, IIRC (If even touching the tag it zombiefied the entire post). It’s something about that tag which is evil. :slight_smile:

// Rolf

I’m getting some weird behaviour too, can you try flattening all the inputs to Cloud Display instead of grafting? Does that make a difference?

I wasn’t even aware non-admins could see it. I thought it was just a way for mcneelies to keep track of unanswered topics. Sounds like it either needs to be fixed or removed then…

Flatten the output of the Gradient worked. But shouldn’t there be no difference if I display 500 items in one branch with 500 colors in the other branch or 500 items in seperated branches with 500 colors in seperated branches ?

Should indeed, but at least we’re both seeing the same bug. The coordinates in a single cloud are stored together, and they all share the same size. I cannot just merge all the coordinates into a single huge cloud, at least not when their sizes differ.

Having everything in a single list also helps with z-sorting, although I note that we’re doing a terrible job of that as well. I’ve put it on the list, it probably makes the most sense to redo the whole approach since it’s now easier to have OGL shaders in the Rhino display. RH-45575

1 Like

Take a look at this; I just tried to reproduce. This my not be covering all cases that people have experienced, but this is definitely once of the causes, since I could reproduce it: