Closed Polysurfaces Losing Surface Curvature When Using Boolean Commands


#1

I am fairly new to Rhino and I keep running into problems when I am using boolean commands. I am creating a digital replica of my chipboard topography that I can use in my 3d renderings. It is not that complex. I start by making my topography lines on the C-Plane using the CONTROL POINT CURVE tool. then I move each closed curve vertically up or down to be at the correct height. Next, I have done a few different things to see if it fixes the problem.

  1. I use the EXTRUDECRV command to extrude each curve 1’ then I CAP each open polysurface

  2. I use the COPY command to copy each closed curve vertically 1’ then I USE the LOFT command to create a open polysurface which I CAP

  3. I use the PLANARSRF command to turn each closed curve into a closed surface. Next I use the EXTRUDESRF to extrude the surfaces 1’.

All of these steps have still had the same problem occur at some point when using boolean options.[SEE BELOW]. Its hard to replicate the issue so its even harder for me to pinpoint. Basically, my vertical surfaces do this randomly after some boolean operations. They are fairly simple operations and this happens at random places that don’t even seem like they should be affected by a Boolean operation. Its almost as if the surface doesn’t recognize the control point curvature and instead creates a curve from the points of the curve. But it also stops being vertical in nature as well so I am at a complete loss.

The only way I have been able to rectify this is to use the REBUILD command and change the amount of control points on my OPEN PLANARSRF after using the LOFT command and changing it to a ridiculously high amount. But as you can imagine this creates quite a bit of trouble with my computers ability to process anything quickly and there is a lot of lag when changing my views, panning, etc.

If anyone can help me I would greatly appreciate it.

This is wireframe of one of the places its happening. As you can see it doesn’t look like anything should be wrong:

This is a shaded version of the same view:

The three different colors are all different layers and each is a Closed Poly surface. In this example the layers were created using a tight loft (see method above for more details) and the curves and surface curvature lined up perfectly. Following a boolean union of the sheets this is what happened.


#2

That just looks like the render mesh settings, it has nothing to do with modeling technique. The mesh is an approximation.

Warning: getting a layered model like that to look perfectly ‘smooth’ shaded is going to take a lot of polygons.


(David Cockey) #3

Follow on to JimCarruthers response. Go to the Mesh panel in Properties and adjust the mesh settings for a more refined, denser mesh.